Website not redirecting to index.html


#1

I’m helping a friend with his dreamhost account. I had a index.html in the root directory. It was automatically going to it when i did website.com. Now, when I go to website.com, I get this.

Forbidden
You don’t have permission to access / on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

If I type in website.com/index.html it works, but why’s it not working by just the .com?


#2

I might be misunderstanding the problem, but I believe that what you need to do is move index.html and all other files (the linked files and what not) to ftp://website.com/website.com

Is that what you were asking?


#3

That’s where it is though… I can access it if i type in the index.html file as in www.mywebsite.com/index.html. But If I just go to www.mywebsite.com, it won’t automatically load index.html


#4

Check the capitalization of your index file. index.html is treated differently than (say) INDEX.HTML

Mark


Save $50 on DreamHost hosting using promo code “SAVEFIFTY” ( DreamHost Promo Code )


#5

it’s index.html


#6

can u post ur url?


#7

You can try a different default page name that DH recognizes like: index.php, or you can add a default in your htaccess file:

DirectoryIndex filename.html

This would cause filename.html to be treated as your default page, or default directory page. You can also append other filenames to it. You may want to have certain directories use a script as a default page. That’s no problem too!

DirectoryIndex filename.html index.cgi index.pl default.htm

http://www.javascriptkit.com/howto/htaccess6.shtml


#8

Which raises the possibility that it is a setting in the .htaccess file that is causing the original problem.

Do you have a .htaccess file in your root directory? Note that it is a hidden file, you may need to configure your FTP client to show such hidden files.

Mark


Save $50 on DreamHost hosting using promo code “SAVEFIFTY” ( DreamHost Promo Code )


#9

I don’t have a .htaccess file there. I did accidentally upload a php uploader script to my root directory, but then I copied and pasted all of it’s information to another folder, so that could have affected it. But I don’t have a .htaccess or any file that it could have left behind.


#10

I’d rather not post my url at this point, as I’m not the one running the site, but if I can’t get it to work in any way I will.


#11

well, it may not work, but Tyy clearing out yourBrowser’s cache and loading the page again. You might also check it from an other computer as well.

We only ask for a url to help you with testing. Sometimes it’s easier to see werhe a problem is. I’m pretty sure no one here will try and hack your account. But just do whatever you’re comfortable with.

-Matttail


#12

EDIT- Nevermind, I got it, thanks for the help. Apparently a .htaccess file in a different directory under my new uploader was doing it. I deleted it from there and then reuploaded it, and now the index loads fine. Kind of strange, but oh well, it works now.