Website not loading at all

wordpress

#1

Not really sure where to start with this process. I have a domain which was fully hosted and registered with dreamhost. I had a wordpress blog installed on it and it was working decently. I decided to uninstall wordpress and move the blog to a subdomain. I then uninstalled wordpress one-click from the domain and deleted the mysql database. Then I set up the domain to be fully hosted by dreamhost.

Ever since then, it won’t load at all. I can confirm in my ftp client that there is no htaccess file, no php, no database stuff whatsoever that I can see in the domain’s directory, but I do have an index.html. however, the site doesn’t load. It just gives a Server not found error page. My blog subdomain (blog.thomstitt.com) is, however, working fine, and I am able to access the ftp directory for thomstitt.com. So I tried setting up the main domain just to redirect to the blog subdomain as a temporary fix - alas, the goggles did nothing. “Server not found.”

Any ideas as to how I should go about troubleshooting and fixing this?


#2

When you went to the one-click install are you sure you clicked custom installation? if you had picked simple the files wouldn’t actually be on your account.


#3

Ah, good call, I should have clarified. When I FIRST set up my wordpress on the domain, I set it up as a simple one-click. Stupid idea. This was the main reason I wanted to start over.

The blog.thomstitt subdomain is a custom install. THAT one works! I uninstalled/removed the original one-click simple install on the domain as well as deleted the mysql database. Now all that’s set up for the domain is a redirect, but it’s just not working at all. I wonder if my rapid-fire installation>uninstallation>hosting>redirect might have just screwed something up? Awakened an old glitch demon.


#4

Okay, just want to report back with a solution to the problem. I contacted Dreamhost support because I really didn’t know what else to try. I’d like to share the response in case this comes up for anyone else:

it looks like something did go wrong, likely by my making way too many changes to the hosting settings in too brief a period. But if anyone else is having similar troubles, you can try the above!


#5

I’m trying to wrap my head around your problem. So … you did a custom install of WP on your sub-domain and that works. You don’t really want the blog on a sub-domain you want it on your main directory instead and have not been able to get it to work so you want to redirect all requests to the main domain instead but haven’t been able to?

OK now… when you log into your control panel and go to One-Click Installs and click on Manage Installed Applications do you see a WP install listed for your main url? If not you haven’t actually done it. If that is the case go back and do the WP custom installation. It is going to have your domain name in the drop down box so pick it. Don’t put anything after the / unless you want it to be in a sub-folder.

If that doesn’t work for you I don’t know what else to tell you other than get someone to do it for you if you can’t handle it yourself.

As for the redirect, open up your favorite text editor (notepad will do if there is nothing else) and make a .htaccess file upload it to your main directory:

Redirect 301 / http://blog.thomstitt.com