Website changes not taking effect


#1

I’ve been experiencing problems with my websites over the past few days. Specifically, any files that I change (upload via FTP) are not taking effect – it’s as thought the entire site is cached somewhere else.

I see all of my files in my FTP folder, however, all of the content that appears in the browser is old. I’ve tried clearing all local caches, and I’m using multiple browsers, but all yield the same result.

I’m totally at a loss and would appreciate suggestions.

Thanks.


#2

Check your paths against the “web directory” for the domain as shown in the Web Panel.

Go to http://web-sniffer.net/ and submit a URL to an image file (or rename CGI scripts with a .txt or other text/plain filename extension)

The HTTP Response Header section should have a “Last-Modified” header with a value matching the time you uploaded the file.

Try deleting a file and see if you get the expected “404 Not found” response.

:cool: openvein.org -//-


#3

Thanks for your response.

Paths are indeed the same as the web directory (in the Web Panel).

Web-sniffer shows the incorrect modification date (i.e., it is showing the date for the old file, not the new one).

I do not get a 404 if I delete a file – in fact, no changes of any kind have any effect.


#4

I should also mention that the site(s) itself is working perfectly fine: I just can’t make any changes – or, to be more accurate, any changes I make are simply not reflected in the browser.

This all started happening just a couple of days ago, and to my knowledge/recollection, I haven’t done anything to the site in that time.

I’m totally stumped!


#5

It could be a server move gone bad. Try refreshing the system by editing the domain and hitting the Fully Host This Domain Now! button again.

[color=#00CC00]Panel > Domains > Manage Domains > Edit[/color]

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#6

Again, I appreciate the help.

I tried that button (“Change fully hosted settings now!”) before, and then again now per your advice, but that didn’t work either.

Anyone have any other suggestions? Keep 'em coming please! :slight_smile:


#7

What’s the URL for your site? And what’s the URL of a file you’ve changed? And if you add a file, it doesn’t show up?

-Scott


#8

It really sounds like a web directory problem that Atropos had you check as a first step.

Another thing you can try is moving the domain into another user’s userspace, making sure to select the “Copy files” option while doing so, wait 10 minutes then test the ability of that user to change files. If it works as expected, rename the folder at the old account to domain.com.old and repeat the moving process to move the domain back from the new user to the original user as a fresh copy.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#9

Scott,

URL is http://morris-photographics.com/

File(s) changed: every HTML file inside inside of this folder/URL http://morris-photographics.com/gemtec/

Correct, none the changes take effect.


#10

@sXi: Thanks, I’ll give that a try.


#11

Is morris-photographics a WordPress site? Do you have any Caching turned on? I tried going to:
http://morris-photographics.com/gemtec/environmental/images/

Just to see if I could get a directory listing, and WordPress intercepted the request and sent me to its Page Not Found page. If you’re using a WordPress cache plugin, turn it off and see if the changes show up.

-Scott


#12

Nope, the site is not a WordPress site – it’s a good old-fashioned hand-coded site. :wink:

Anyway, I figured out what the problem was! Turns out that my site was moved from fud.dreamhost.com to wario.dreamhost.com; but all of my files were still present on fud and my login/password remained the same.

So it turns out that the original post was technically correct (that the path was different), but because I was using FTP on my end and checking the results in the browser, I couldn’t see the problem.

It wasn’t until my login on fud went dead and I noticed wario in the panel that I thought to log into wario.

Thanks so much for your assistance, everyone!


#13

The thought of a changed host had crossed my mind, except that if you FTP to morris-photographics, that would be the same IP address you’d get with your browser. Weird.

-Scott


#14

Thanks again for helping, Scott!