WebLog Expert

apps

#1

I’ve recently installed WebLog Expert [logging software] and it asks me for the location where the logs are stored. When I put it in, it says it can’t find the location. When I try to view my stats via the DH’s panel, it shows the first web page of my site with no stats on it. I also have another site with DH and when I try to view my stats there and put the user name and password on the mywebsite.com/stats/ page, it shows me the login screen aka .htaccess type of thing, and the password is NEVER correct, even though I know it is. Is anyone familiar with sort of problem?


#2

I’ll try that right now…


#3

$&^@($&^%*#! It worked, man! First I, by mistakenly thinking my WebID is my email, put it in, and it didn’t work, but then I got it. However, the other problem still persists: on my other site [blog] I can’t view any stats. It doesn’t even give the login screen.


#4

I really sounds to me like you are dealing with three different issues here.

This is most likely a matter of simply getting the correct path, and it can be a bit confusing given the way Dreamhost logs directories are set up (symlinks, etc.) It’s hard to tell exactly what the problem is, as you did not include a snippet of exactly what path you used. My suggestion is to carefully explore the “logs” directory in your main user directory (/home/user/logs/), to find the appropriate location for WebLog Expert (I’m not familiar with that particular program) and try again. Alternately, you could post the path you used here, and we might be able to tell more about what is going on.

This looks like the natural result of your domain running a program where .htaccess based Apache re-write rules are interfering with urls that try to access your stats directory (WordPress, Drupal, Joomla!, etc.). This is easily enough fixed using information from this Dreamhost Wiki Article on mod_rewite or this Dreamhost Wiki Article on Making stats available with htaccess .

This could simply be a matter of confusion regarding which user name/password combination (webId, shell/ftp user, etc.) you should use (assuming of course, that there are not “UpPer/LOweR Case” or other common “login problem” issues). You can confirm the correct user/pass to use, or add new user/pass combinations from the Control Panel Site Statistics management page, by clicking on the “# users” link in the “Stats Users” column adjacent to the domain name in question. From there you can edit passwords, add additional users, etc… Often, simply inspecting the “user” that is currently set up will indicate which user/pass you should use; you can always change the password there, or add another user/pass combination if the indicated user is not enough of a help to get the correct password to be accepted.

Good Luck!

–rlparker


#5

Yep… I was typing while you and ardco were solving your first problem…check my preceding post on your “blog” related stats issue. :wink:

–rlparker


#6

Ok, problem #3 has been resolved since I was able to access the logs, and I can say because of my ignorance.

You mean it’s dreamhost.com/home/user/logs?
I was able to import the log files into WLE, but it said that it can’t read them.


#7

No. I’m talking about the path on the server to the directory where you user’s logs are stored. These are not reachable via a web browser without using a script to access them as they are not in a web-accessible directory. The path you just described does not exist, and if you treat it as a url instead of a path, it also does not exist.

Your site is stored in the directory /home/yourusername/yourdomain.tld, where “yourusername” is your user and “yourdomain.tld” is your domain name. Your log files are stored on the server in the directory /home/yourusername/logs , with the logs for a given domain stored in the directory /home/yourusername/logs/givendomainname/ .

I you do have your path set up in such a way that WLE could “import them”, but could not read them, it is possible that they are not stored in a format that WLE recognized - Probably a good candidate for an inquiry with the WLE folks :wink:

–rlparker


#8

Ok, got it. But how I access the logs if the directory /home/yourusername/logs is not web-accessible?


#9

You can access them via an ftp server, or the shell, but not a web-browser (unless you write a script to read these files from outside the web-accessible directory tree).

I popped over for a quick look at the WLE website, and think I may see the problem - you can set your WLE profile up to use either ftp or http. On Dreamhost, given where the files are stored, you want to use ftp. Check out this WLE help page on setting up profiles, and the linked ftp configuration help notes page for some program specific info on setting up WLE on your computer.

–rlparker


#10

Nah, nothing works. I tried /home/myusername/logs, messing with the settings, etc. Nope. I guess I’ll just stay with the DH’s reports. However, I still don’t get the blog/log thing: why does it only display the main page with nothing on?


#11

Without seeing the site, or your .htaccess rules, I’d only be guessing.

If your blog is using Apache rewrite rules in a .htaccess file, that is most likely the culprit. If you want to post the url to your site that is having the problems, and/or post the contents of your .htaccess file and tell me what blog software you are using, I’d be happy to look at it further.

–rlparker


#12

Ok, I was skeptical at first, buy now…what the hell. It’s www.billdexter.com


#13

I got it to work, thanks, guys! It was just my stupidity, I guess. What I did was: I went to SmartFTP and tried to access tab.dreamhost.com and it didn’t work because of wrong password [I’ve changed the pass recently]. Then I tried it again and it worked. I saw a weird address in the URL bar, so I put that address into WLE with the correct [same] password I used in SmertFTP, and it worked! Now I can look at my log in graphical mode!


#14

From looking at the url you provided, your site is, in fact. running a WordPress blog package and is using the “pretty urls” feature, which means that an .htaccess file in your “billdexter.com” directory is using apache rewrite rules to intercept and translate urls.

This is why you are not able to see your stats, and why entering http://billdexter.com/stats produces a “WordPress” not found page.

I have already pointed you to the appropriate Dreamhost Wiki articles where you will find detailed instructions on how to fix this.

Follow the instructions in those wiki pages, and modify your .htaccess as indicated, and your problem will be solved. Good Luck!

–rlparker