I established webDAV service via the “goodies” menu. my domain name is ophelia1.net. I placed the webDAV files in a directory from the basic domain: Ophelia1.net/xxx.

I’m trying to access the root directory of ophelia1.net. I’m trying to log in from a Ubuntu 8.10 box. I’ve used “putty” as well as ssh. In both cases, the system will not accept my password. I can’t think of a thing that I’ve changed. I can’t find a place within the dreamhost panel that lets me change/reset information for just this domain. I can find it just fine for a different domain I host there.

I’ve opened support tickets, but those folks are seriously overworked and I’d like to resolve this before I head to bed in an hour if I can.

Any help you can give me will be appreciated. Said appreciation will be expressed by launching a number of questions I’ve been saving up until such time that I found someone to dump them on.

tnx in advance for your help.


You can’t access the webDAV by SSH…

Once you make a directory a webDAV file, it can only be accessed through the webDAV protocol.

I could be wrong, but this is my take on it.

So are you saying the WebDAV install did something to your shell access? Just want to clarify…

Just to recap:

WebDAV has nothing to do with shell access, other than that you can’t manage files in a WebDAV directory since that directory becomes owned by the special ‘dhapache’ user.

Let me clarify. You manage files in WebDAV directory using WebDAV protocol, not other protocols like SSH/SFTP or FTP, much less shell (since you are never ‘dhapache’). Thus for Ubuntu you need to research a solution like http://www.howtoforge.org/davfs_ubuntu to implement on your own computer.

Second, it sounds like you are new to DreamHost, and need something things pointed in the Web Panel:

Uh, WebDAV credentials are separate from system user credentials. The system user credentials are managed under the “Users -> Manage Users” panel. You should get a list of users, and an “Edit” button on the right. You can’t retrieve passwords here but you can set them. These credentials are used for SSH, and FTP/SFTP. But you have to explictly enable SFTP and/or Shell for a system user on this panel.

Goto the “Domains -> Manage Domains” panel, and you should be able to find the domain in the list here. It should have an “Edit” button in the “Fully Hosted” column, but first notice the User next to the words “Fully Hosted”. That tells you what system user to log into SSH as to manage files served for that domain. After you click on “Edit” you can change the user.

:cool: openvein.org -//-