webDAV on Mac


#1

I’m having difficulty getting a webdav folder to work on my mac. The setup is really straight forward. I first set up the webdav folder on dreamhost and waited for it to take effect. Then I went into the finder and did cmd-k and set the url to my webdav-enabled folder. It found it just fine and I tried to upload some canon raw image files (.cr2) which are around 6 - 7Mb each. I would get message that said the connection with the server was interrupted and finally I would have to click okay. It would indicate that the file had uploaded and I would see the file icon and name in the folder but the file would be 0Kb in size.

I then used a trial version of transmit app (which is only hindered by a 10 minute time limit) to upload a cr2 image using transmit’s webDAV capabilities and it seemed to load the whole thing until the last possible moment it said that the connection was reset by the server and could not complete. The file had like 45Kb and was unreadable.

So what could the problem be here?


#2

Wow, Mike. I am having the exact same problem. I’ve tried uploading the same file from Windows & from my Mac, and it keeps crapping out at the end of the upload. It seems to be just larger files that it’s choking on (this one’s 7.5 MB). I’d love to find a solution.


#3

WebDAV has never been a reliable (…or terribly secure) protocol IMHO; I stick with good old FTP.


#4

You can even use rsync over SSH, which is quick, efficient, and secure.

-Scott