Webalizer and libpng


#1

Webalizer has stopped working for me as of Mar. 16. Running it from the command line yields this error:

./webalizer: error while loading shared libraries: libpng.so.2: cannot open shared object file: No such file or directory

Is this something I’ve done, or some other change? Is it easily fixable?

As might be indicated from the fact that it stopped working a month and a half ago and I just noticed it today, it’s not something that I depend on heavily, but it would be nice if it worked.


#2

I think I’ve seen this before… you’re probably trying to run an old 32-bit copy of webalizer on a 64-bit machine. Go download a 64-bit version of webalizer and it’ll work fine.


#3

Thanks … started to install the latest release of webalizer, ran into a bunch of install errors, decided I don’t really care enough to troubleshoot for more than 5 minutes, deleted


#4

I ran into the same error too, with my updates ending March 7, 2010. I find myself attached to Webalizer (worked without fuss for almost 5 years configured this way) so I hope to resolve this.

I downloaded the latest version from http://www.webalizer.org/download.html, extracted the files and replaced everything on the server with the newer versions. Upon running in the shell, I got a new error:

What, if anything, is next? Will this not work on Dreamhost any longer?

Thanks.


#5

I may have figured out a workaround and must say I have not done this much on the command line perhaps ever (including a rather empowering first use of “wget”).

I ended up compiling a new binary with an attempt to tell webalizer where the find the elusive libdb-4.4.so when using the latest version 2.21-02.

Here are the commands I used while in my home directory:

wget ftp://ftp.mrunix.net/pub/webalizer/webalizer-2.21-02-src.tgz tar zxf webalizer-2.21-02-src.tgz cd webalizer-2.21-02 ./configure --prefix=$HOME/webalizer --with-libdb-4.4.so=[result of running locate libdb-4.4.so in shell] make make install

There was still an error about finding libdb-4.4.so with the report that geographic lookup would not be possible. Which is all right since this had not worked before either and was not a concern of mine. There was also a lot of warnings as a result of the “make” step that I could not quite decipher.

I navigated to the new /home/USER/webalizer/bin and ran:

Reported “Warning! 3 month gap detected” since it had been since March, but otherwise a success. The only lingering issue was how the current log files only of course cover one day, so I may create some new conf files to recover from what logs are available (generally only the minimum 3 days for me)…if I care that much of course!

Why do all this? I simply find the Webalizer results to be the most useful of any stats I have seen. The default DH stats are hard to read (but I did not turn them off so I’ll have an idea of these missing months) and anything with analytics (Google, etc.) will not work for my main site of downloadable files–which cannot contain the required javascript codes.

Anyway, hope this helps someone else coming later, and if anyone has ideas on compiling with the correct libdb location please share. I used the exact results from the “locate” command, but I wonder if I was one of more directory levels off, revealing my general unfamiliarity with the inner workings of unix.