Web Server Write Access - Elgg Installation!


#1

Hi,

I am attempting to install Elgg and have managed to get through most of the bumps along the way apart from the following error message:

“You need to create the directory /blah.com/whatever/data/ with web server write access”

I have used chmod to change the access levels to public i.e. 0777 and globally write access is enabled.

What else do I need to change to get this to work?

Any help would be most appreciated!!

Thanks in advance for any of your time :slight_smile:

Ky


#2

[quote]“You need to create the directory /blah.com/whatever/data/ with web server write access”

I have used chmod to change the access levels to public i.e. 0777 and globally write access is enabled.

What else do I need to change to get this to work?[/quote]
First of all, in spite of the elgg instructions, sufficient permission for the web server to write to directories in the DH environment is 755. This is due to DH use of suexec, and you will find you should never need to set anything to 777 or 666 in the DH environment running common web application scripts (in fact, doing so will often “break” stuff on DH!). Set the permissions on that directory to 755, and on your templates to 644, and you will be good to go in that regard. :wink:

I’ve successfully installed elgg, and have made some other changes n the config.php file that make sense in the DH environment, and improve security. My changes are as follows:

1.) // You may change these values to something else but you must ensure that
// the user the web server process runs as is able to read and write under
// these permissions.
$CFG->directorypermissions = 0755;
$CFG->filepermissions = 0644;

  1. I place my “data” directory outside my web accessible space, and corrected the config.php accordingly. For example, instead of using /home/username/blah.com/whatever/data/, I used something like /home/username/whatever/data/ so that that whole directory would only be accessible from the script, not from the web.

Additionally, as I have not gotten around to “curlifying” the “explodeping” module (which currently uses url_fopen and therefore will not work on DH), I simply deleted it’s directory so no errors were generated (I didn’t want that activity anyway!).

–rlparker


#3

I’m getting that same error…

“ERROR: You need to create the directory http://sub.domain.com/sub/directory/data with web server write access”

I did what you did and chmodded accordingly… But I continue to be getting the same error. Everything in config.php should be correct…


#4

Shrimp,

I don’t know what else to tell you; that configuration works for me. The only thing I can suggest is to go back and double/triple-check all your settings and your permissions.

Make sure you clear all your caches before proceeding.

Don’t get confused about the instruction line “You need to create the directory http://sub.domain.com/sub/directory/data with web server write access” - just make sure that your data directory is set to 755 permissions and that it’s true path on your server (wherever you created it) is set correctly in the config.php file.

–rlparker