Web.py - getting suexec failure


#1

Hi

I’m trying to get web.py working.
I was trying to follow the instructions at http://wiki.dreamhost.com/Web.py
but could not because the referenced fcgi.py file does not exist any more.

I decided to just try getting it to work without fcgi for now.
Using both the sample web.py file on the wikipage and my own index.py I get Internal Server Errors when I attempt to access the page. The contents of my error logs are:

[font=Courier][Sat Mar 31 15:22:07 2012] [error] [client 24.246.58.99] suexec failure: could not open log file
[Sat Mar 31 15:22:07 2012] [error] [client 24.246.58.99] fopen: Permission denied
[Sat Mar 31 15:22:07 2012] [error] [client 24.246.58.99] Premature end of script headers: index.py
[Sat Mar 31 15:22:07 2012] [error] [client 24.246.58.99] File does not exist: /home/deshwar/headway.deshwar.com/internal_error.html[/font]

I made sure my .py file had the permission bits set to 755.

I’ve tried googling but most suexec failures seem to be solved by setting the permission bits but that’s not solving the problem in my situation.

Any advice on how to fix this?


#2

Three days ago, Dreamhost decided to shoot themself in the foot, so they enabled “Enhanced user security” for every user, which leads to the same error you provided, because executable (Python in your case) now has no access to your files. Go to Panel and turn “Enhanced Security” off for the “deshwar” user.


#3

I have this same exact problem. I’ve tried disabling Enhanced Security on both the domain and the user with no luck. My static files actually get hosted and I can go to /static/kitten.jpg but I can’t actually get to my Web.Py app.

Any help would be appreciated.


#4

Hey Aditya

Yeah, that suggestion didn’t work for me either. I’m honestly not sure how I got it to work, but I had to start by building my own local python installation and I think that fixed the issue.

Best of luck!