Web directory for new sub-domain


#1

When creating a sub-domain we get a text box to set the path under a given user. But anything set there is changed when the textbox loses focus.

After creating a subdomain we can change the path. After a couple minutes favicons are added to the new path, confirming the change has taken place.

Is this a bug or a feature? I don’t remember it working like that before.

If we can’t set the original web directory, I think the config page should disable that textbox, and be explicit with a bit of text about how that works, rather than providing a text box that doesn’t work.

Thanks.


#2

That doesn’t sound right — the web directory field is only supposed to be updated automatically when you change the domain. Once you’ve picked a domain name, you should be able to change the web directory to whatever you like.


#3

From my experience it works like this:

  1. If the “Web directory” field is blank, set it to the value of “Domain to host”
  2. If the “Domain to host” is changed (but not set to blank), set “Web directory” to the same value

And of course that means one should specify the “Domain to host” before specifying the “Web directory”. I’m using Firefox and Chrome on Windows XP.


#4

There’s no disagreement. What I’m saying is that beyond #1 and #2 above, if Web Directory is set by the user, it should remain set. Right now for a new subdomain it re-sets to Domain To Host and cannot be changed until after the subdomain is created.

Browser shouldn’t be a factor here, but I’m using FF17/Win7.


#5

I use portable Opera for my DH stuff and Panel is flawless.

Might just fire up FF17 and try this out.

brb…

Back. The script seems to work as intended here, at least visually. Win8 FF17.

Were you talking about the script functionality within Panel, or is it a case that no matter what /subdir/ you put in initially it creates the path as /user/sub.domain.com regardless of your initial settings, requiring that you need to log back in and set it again?

Side note: I couldn’t log in to Panel using my abcdef00 id – had to use my email. Weird.