ViewVC Support

apps

#1

Hi, I’m brand new to dreamhost and so far I’m loving it. This is the first time I’ve ever had webhosting so I’m sort of a newb. One question that I have so far is how to install ViewVC on your hosting area? I’ve uploaded the ViewVC stuff to my hosting area, I’m ssh’d into my web hosting area. I typed in the ./viewvc-install …/Installation/ViewVC … And the view vc installation comes back saying “: No such file or directory” . Has anyone else tried installing ViewVC yet? I LOVE the way they display information about your repo. Thanks for the help. Sorry if this is a newbtacular question :smiley:


#2

first make sure that you upload the files into the right folder.

There are three folders in your web directory. The files should go into “yourdomain.com” folder.

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color]. Sign Up NOW


#3

Thanks, wow you’re great. Fast response time. I’ll give it a whirl and see what happens :smiley:

Edit:

arggg… Didn’t work… this is what I see.

[gingerale]$ ls
Installation Maildir logs ****.com svn
[gingerale]$ cd ****.com/
[gingerale]$ ls
ViewVC cgi-bin img index.php
[gingerale]$ cd ViewVC/
[gingerale]$ ls
CHANGES bin lib tools viewvc.org
COMMITTERS cvsgraph.conf.dist notes tparse windows
INSTALL docs templates viewvc-install www
README elemx tests viewvc.conf.dist
[gingerale]$ ./viewvc-install
: No such file or directory


#4

:stuck_out_tongue:

I’m not familiar with ViewVC. But if you have this error message “no such file or directory”, it is possible you put the files in the wrong folder.

Good luck!

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color]. Sign Up NOW


#5

I’ve tried a million things… still the same old
: no such file or directory …

When I try to do obnoxious things like ./dlfwkjdfwdj
atleast it says -bash no such file

Only when I try to run that install file does it say : no such file without anything else. …

This doesn’t seem like it should be that hard. I followed all of the directions in the INSTALL document that came with it. Any help on installing this would be greatly appreciated.


#6

I tried and got:

The top of the script is: #!/usr/bin/env python

If you do: /usr/bin/env python at command line, do you get in python? (Control-D to exit)

----------
[color=#00CC00]ANONYMOUS0 => Max Discount[/color], [color=#6600CC]ANONYMOUS2 => Max Discount less $1[/color] or Cut the code, [color=#CC0000]it’s their birthday:[/color] [color=#00CC00]9999 => $99.99 Off[/color]


#7

[~/******.com/ViewVC]$ /usr/bin/env python
Python 2.3.5 (#2, Oct 16 2006, 19:19:48)
[GCC 3.3.5 (Debian 1:3.3.5-13)] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.


#8

I think i’ve figured out the problem. I got a direct dump from the current SVN repo… So It’s probably not released. I’m goign to try 1.0.3 and see what happens.


#9

Ok that didn’t work either.

Back to the basics… When you download the .gz where are you extracting it to ?


#10

GOT IT!

I was just downloading the ZIP and extracting it then copying it over. The last time I tried I actually downloaded the .gz and did a tar xzf … So what’s the difference I guess ?


#11

Could be. I did:

wget http://viewvc.tigris.org/files/documents/3330/34803/viewvc-1.0.3.tar.gz
tar xvzf viewvc-1.0.3.tar.gz

----------
[color=#00CC00]ANONYMOUS0 => Max Discount[/color], [color=#6600CC]ANONYMOUS2 => Max Discount less $1[/color] or Cut the code, [color=#CC0000]it’s their birthday:[/color] [color=#00CC00]9999 => $99.99 Off[/color]


#12

Worked for me. Hey I really appreciate your help! Thanks a million.


#13

You’re welcome.

FWIW, I tried the zip and got the same ‘no such file’ error. dos2unix on viewvc-install got it to run, so it looks like it’s a CR/LF DOS/UNIX difference thing. You’d need to convert more files, so getting the tar.gz is the way to go. :slight_smile:

Now you can go update the wiki. :cool:

----------
[color=#00CC00]ANONYMOUS0 => Max Discount[/color], [color=#6600CC]ANONYMOUS2 => Max Discount less $1[/color] or Cut the code, [color=#CC0000]it’s their birthday:[/color] [color=#00CC00]9999 => $99.99 Off[/color]


#14

I would love to update the wiki. I would want to wait until I have it configured and working well first though. I’m still pretty noobish. Plus i’ve been up all night due to a combination of a livid interest in web stuff and someone SOMEHOW getting paint thinner in my heating unit which now billows out paint thinner fumes all night long :frowning:

If I have lots of typos or don’t make sense at times… Blame the fumes.


#15

Hello, thanks to this thread i managed to install ViewVC without problems (i also got robfrog’s error).
(By the way, ViewVC’s latest version is 1.0.5)

I don’t understand how you managed to get it working tho. I apparently can’t get the server to run the cgi scripts (unless there’s something else i’m doing wrong).
I tried following the steps in this Dreamhost’s wiki:

I could be wrong, because there’s no way to tell if the cgi script is being executed. But then, if it was, the browser would load ViewVC, right?
I installed ViewVC in the main public folder, made a directory called cgi-bin, and put the script there, like the wiki says.
Installation was correct, at least the installer told so. The last step was to get the viewvc.cgi script running…

Does anyone else have ViewVC running in their host? How did you make it happen? Please, help me on this one. :frowning: