Very slow again!


#1

Cached pages are still up (although very slow) but I am having loads of problems again just updating content on my site. Page edits are crashing, database connections being lost, page previews just dropping out.

Come on DH, sort these issues out. It’s almost constant and getting very boring now!


#2

I thought maybe it was just me since I am a new customer but I guess not :frowning:


#3

No, not just you :wink: I’ve been getting this for months but no real solution from DH on the issue. The suggestion first was it was the site having too many pluggins, so I removed everything I wasn’t using. Then it was suggested the images on the site were too big so I downsized all of them. Then it was the social plugin, so I removed that. Most recently it was ‘certain’ IP addresses, but I have very little traffic and the bandwidth is very low on the site.

It seems it is every time I try to update the page content the servers struggle - does this not suggest to DH that there might be something wrong with the processing on the servers? I would think that I am allowed to update my WP site content so don’t see why I am strangled or the server cuts out every time I try to do anything.

:frowning:


#4

You’re still on PHP 5.2, SafariDude, which I know I’ve mentioned uses more memory than 5.3 (or 5.4, which you also have available now). And you can use Google PageSpeed on your account to help a lot. It works fine with WP Super Cache.

If the problem is happening when you post content, however, that implies you have a plugin at fault. If I had to cherry pick, I’d start with “google-sitemap-generator” - does that run every time you save a page? Also, ironically, if you’re not getting a LOT of traffic, check your WP Super Cache settings. You don’t have to flush the whole cache when you post, and you can limit that to save memory.


#5

Might be a stupid question, but is it easy and safe to upgrade PHP? And how do I do it?

Not heard of Google Pagespeed - I’ll check that out, thanks.

Not sure how the sitemap generator is set up - but I wouldn’t be surprised if it runs when a page is updated. i’ll check this out. Do you recommend that I run the update only when I’ve updated everything?

For the Cache settings I’ve turned off the garbage bin settings so nothing goes to garbage - I assume this keeps all pages cached until that specific page is updated? This seems to work OK most of the time but obviously the cache is ignored when I log on and I’m a known user - this is when I see slow responses.

Traffic wise, I’d be surprised if I get 10 - 20 unique visitors a day at the moment. I’ve had Google adwords running but this was spent out after 10 clicks so nothing major there. I had a Facebook push yesterday and today which may have increased traffic a bit, but I’d guess still in the 10 - 20 bracket. It scares me that if I do increase traffic to 100 + how DH servers can cope.


#6

Not a stupid question at all!

Go to https://panel.dreamhost.com/index.cgi?tree=domain.manage& and click on ‘Edit’

Under “PHP mode:” change it to 5.3 FastCGI or 5.4 - I’m using 5.4 on my WP sites right now.

That’s also where you can click on “Page Speed Optimization?” which will activate Google PageSpeed.


#7

It’s always easy when someone spoon feeds you :slight_smile: Thanks for the steps - I’ve done this so hopefully this will all help. Cheers