Very important file being unnecessarily cached


#1

The webserver setup you guys are using is caching a very important file that needs to be CHANGED 2 days AGO!!! Webservers are not supposed to operate like this! PLEASE CHANGE THIS FILE IMMEDIATELY!!!

The file in question is http://www.sunlit-software.com/software/ShellFTPinst.exe

IT DOES NOT CORRESPOND WITH THE FILE ON FTP.

Please DO NOT CACHE MY FILES!!!


#2

YELLING in “caps” on this forum won’t help…

This is a “customer-to-customer” forum, and while DH staff occasionally checks in, it’s not something you can count on. If you feel that your file is being cached, you should submit a support ticket via the control panel to bring the matter to Dreamhost’s attention.

Also a “tip” on “caching”: That file may be cached at any of several places along normal internet routing, and it may* or may not* be the result of anything DH is doing.

You might try deleting the file from your ftp space, then browsing to it and getting a “not found” before re-uploading the file with your ftp client. This sometimes “works” to cause a “refresh”.

FYI, the version of the file displayed to my browser is dated 17-Nov-2006 23:05, and shows as being 348K in size.

–rlparker


#3

I’m guessing it’s being cached somewhere between you and DH. I’ve never seen a file change that wasn’t instant.


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


#4

From looking at his timestamps, I’m thinking it is also possible that his ftp client “thinks” a newer version of the file is the same as the old (and maybe didn’t actually upload the new version as a result) - some ftp clients I’ve seen are flaky on this :wink:

–rlparker


#5

It looks like you have the problem resolved, as I see the new file ShellFTPinst-free.exe 19-Nov-2006 17:10 348K is now being served.

I’d look hard at how my ftp client handles files with the same filename (and what it thinks does, and does not, represent a “changed” file).

I’m glad you got it sorted, and Good Luck with your program!

–rlparker


#6

Thanks rlparker.

While this may be good for people who go to the download page, many, many, many pages hotlink ShellFTPinst.exe and it needs to be the 348kb one and not the 330kb one.

I still get the 330kb one but you guys may be right about it not being DH’s fault. I am not sure why I get this. My theory was that DH cached it due to a big DDOS so that all these people could still get the software.

Very hopefully I can have the 348kb file served to all, or else I am losing money.

-jon


#7

I understand…have you tried throwing an .htaccess based 302 re-direct at it? (for a temporary fix till you can get it all sorted).

While not a "real"solution, it will solve the problem of existing links to the ShellFTPinst.exe file. :wink:

Just a thought…and Good Luck!

–rlparker


#8

One more thought…If DH was caching it, I should be seeing the smaller file size, but I’m not. To me, since you are still seeing the smaller file and I am not, (pulling on my asbestos pants :wink: ), it looks like your system might be caching it (sensing it is an already download file, etc.) Are you sure you have completely cleared all your local caches?

I’ve recently experienced incomplete cache clearing with Firefox, that was only resolved by closing the browser after clearing the cache; without the browser closing, even though the cache was “cleared”, it retained old info.

–rlparker


#9

When I download the file I’m getting the 348 kB version.