Verification meta tag

wordpress

#1

when i try to verify a site with google i receive this error:
We couldn’t find the verification meta tag

i have add the correct meta in the head section but google can’t find it


#2

To make sure the META tag is present, go to
http://web-sniffer.net/ and submit the URL you are giving Google.

If it is and Google still doesn’t verify, use one of the other methods.

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#3

I already try to solve the problem using the html page verification, but google say:

We’ve detected that your 404 (file not found) error page returns a status of 200 in the header.


#4

Oh, so now you have two problems.

  1. Have you confirmed that the META tag is in the HEAD of your page yet?

  2. Google is saying that when it requests something it knows should not be there, it gets a message that it was there.

This is caused by something you’ve setup that handles missing files instead of the web server. In particular, if you have:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

In your .htaccess file that might cause a problem.

Basically this means If the request is not for an existing file and is not for an existing directory, have index.php handle it. So what happens if index.php doesn’t know it is handling an error? It ends up telling other computers (like Google) there was no error.

So you’ll need to re-think how you are going to handle not found errors. Did you write the index.php script yourself?

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#5

Why not use the other option of using a verification file instead? They asked me to put a file “googleANXHD*E.html” (the garbage characters were some randomstring) in the root directory of my domain. It doesn’t matter what the contents are, as long as the file exists.

-Scott


#6

i haven’t solve the porblem, could explain me better what i can do ? i use wordpress :frowning:


#7

I just ran into the same problem with a couple of my sites that are using Joomla. Even though I haven’t made any significant configuration changes, this is the first time I’ve seen this problem since setting up my Google Webmaster account two months ago. My site is configured to use the OpenSEF plugin, which lets me assign a specific page when a 404 error is encountered.

For example, browsing to “http://domain.com/fakiefakie.html” will reroute me to “http://domain.com/” thanks to the SEO stuff I am using. Once I changed this so OpenSEF doesn’t have a url in the value for “404 Not Found URL”, Google verified me with no problem. It came as a suprise to me too, because I’ve been verified for quite a while. Dunno if this is new, or they just got around to checking me out. They aren’t the most proactive when it comes to spidering me.

It appears that Wordpress supports the same functionality. According to Google, they enforce this because another site could masquerade as you. This isn’t really clear to me but I still don’t mess with “The Google,” especially when I hear how frequently they ban AdSense accounts for unclear reasons.

http://www.google.com/support/webmasters/bin/answer.py?answer=35229&query=404 returns 200&topic=&type=

[quote]We’ve detected that your server returns a status of 200 (found successfully) for pages that don’t exist.

We’ve detected that your server returns a status of 200 (found successfully) for pages that don’t exist. We can’t verify sites with this configuration because it would enable anyone to verify ownership of your site. You can try our meta tag verification method or change your server’s configuration.
[/quote]
In their infinite wisdom, Google has decided that a dead-end failure page is preferably to a user-friendly redirect. Do you have a custom error page? If so, the browser may interpret the result as a success (200) instead of a page not found (404).

My choice was to disable the redirect until I come up with something better. The meta tag solution was a little complicated for my situation, since I am using a CMS.

http://benconley.net
http://teamshocker.com


#8

Thanks :slight_smile:

i have a custom error page 404.php in my theme, but if i delete it all non-existent pages are redirected to the homepage…i already try to delete the 404 page :frowning: :frowning:


#9

up


#10

up :slight_smile:


#11

ignore

-Scott


#12

ignore :slight_smile:

-Scott


#13

Google is right, you know. HTTP status 200 is “OK”; someone requesting a non-existent URL is not ok. Redirecting is ok, but you have to return the correct status code before you do it.

This has nothing to do with how browsers interpret redirects, but with what the server tells the browser the status of the current request is. If an application returns status 200 for an error page, that application is broken (I’m looking at you, Gallery).

Personally, I find it confusing when I go to a specific URL and find myself at the front page unexpectedly. I much prefer a helpful error page with navigation and a search box (and some good guesses as to where I might like to be, if possible). I haven’t read any studies on this, but I’m guessing most users would feel the same.


If you want useful replies, ask smart questions.