Vbulletion issue

apps

#1

// ****** DATABASE NAME ******
// This is the name of the database where your vBulletin will be located.
// This must be created by your webhost.
$config[‘Database’][‘dbname’] = ‘mattaproductionsforum’;

// ****** TABLE PREFIX ******
// Prefix that your vBulletin tables have in the database.
$config[‘Database’][‘tableprefix’] = ‘’;

// ****** TECHNICAL EMAIL ADDRESS ******
// If any database errors occur, they will be emailed to the address specified here.
// Leave this blank to not send any emails when there is a database error.
$config[‘Database’][‘technicalemail’] = ‘matthammond21@hotmail.com’;

// ****** FORCE EMPTY SQL MODE ******
// New versions of MySQL (4.1+) have introduced some behaviors that are
// incompatible with vBulletin. Setting this value to “true” disables those
// behaviors. You only need to modify this value if vBulletin recommends it.
$config[‘Database’][‘force_sql_mode’] = false;

// ****** MASTER DATABASE SERVER NAME AND PORT ******
// This is the hostname or IP address and port of the database server.
// If you are unsure of what to put here, leave the default values.
$config[‘MasterServer’][‘servername’] = ‘mysql.mattaproductions.com’;
$config[‘MasterServer’][‘port’] = 3306;

// ****** MASTER DATABASE USERNAME & PASSWORD ******
// This is the username and password you use to access MySQL.
// These must be obtained through your webhost.
$config[‘MasterServer’][‘username’] = ‘#####’;
$config[‘MasterServer’][‘password’] = ‘#####’;

I edited the config.php like I was suppose to and I keep getting a data error page.

Matta


#2

[quote]// ****** FORCE EMPTY SQL MODE ******
// [color=#CC0000]New versions of MySQL (4.1+) have introduced some behaviors that are
// incompatible with vBulletin. Setting this value to “true” disables those
// behaviors.[/color] You only need to modify this value if vBulletin recommends it.
$config[‘Database’][‘force_sql_mode’] = false;
[/quote]
I’m wondering if that is the problem … DreamHost uses MySQL 5.

Other than that, everything looks pretty good … your hostname is reachable via DNS.

Of course, that error message is considerably less than helpful … make sure you are using your correct MySQL user credentials for user/pass (not your FTP or account user).

–rlparker


#3

when I made the database I made the new user to access it. which is matta and password #####. I don’t know. Never ran into this issue before.

EDIT: I will try reinstalling the package if nothing else.

Matta


#4

vBulletin runs on php5.

Recheck: dbname, username, password.


#5

Definitely, vB runs on 5 , I run it on my VPS.

Three things:

Can you post the actual database error? vB can email you database errors, define ‘technical email’ in the config.php and then try accessing again it will email you the error.

Secondly: Have you renamed config.php.new to config.php?

Lastly, have you actually run the install script? .com/install/install.php

Big Dan proprietor of DJ Talk


#6

WOW! Ok you guys everything works fine I just forgot to run the install.php file. I missed the easiest thing to do. Thanks! Look for my post on organizing my php files.

Matta