vBulletin set-up problems


#1

I’m attempting to move a vBulletin forum from another host to here, and I’ve had nothing but problems today.

First of all, I have vBulletin uploaded (along with the edited config.php file) and every time I try to access it I get a database error.

Here’s what I have for the part of the config.php that I changed to use here:

// ****** DATABASE TYPE ******
// This is the type of the database server on which your vBulletin database will be located.
// Valid options are mysql and mysqli, for slave support add _slave. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
$config[‘Database’][‘dbtype’] = ‘mysql’;

// ****** DATABASE NAME ******
// This is the name of the database where your vBulletin will be located.
// This must be created by your webhost.
$config[‘Database’][‘dbname’] = ‘peaceeyotaforum’;

// ****** TABLE PREFIX ******
// Prefix that your vBulletin tables have in the database.
$config[‘Database’][‘tableprefix’] = ‘’;

// ****** TECHNICAL EMAIL ADDRESS ******
// If any database errors occur, they will be emailed to the address specified here.
// Leave this blank to not send any emails when there is a database error.
$config[‘Database’][‘technicalemail’] = ‘chicken@peaceeyota.org’;

// ****** FORCE EMPTY SQL MODE ******
// New versions of MySQL (4.1+) have introduced some behaviors that are
// incompatible with vBulletin. Setting this value to “true” disables those
// behaviors. You only need to modify this value if vBulletin recommends it.
$config[‘Database’][‘force_sql_mode’] = false;

// ****** MASTER DATABASE SERVER NAME AND PORT ******
// This is the hostname or IP address and port of the database server.
// If you are unsure of what to put here, leave the default values.
$config[‘MasterServer’][‘servername’] = ‘mysql.peaceeyota.com’;
$config[‘MasterServer’][‘port’] = 3306;

// ****** MASTER DATABASE USERNAME & PASSWORD ******
// This is the username and password you use to access MySQL.
// These must be obtained through your webhost.
$config[‘MasterServer’][‘username’] = ‘####’;
$config[‘MasterServer’][‘password’] = ‘####’;

Any obvious problems here? The hostname is the one I created for this database.

Once I get this to work…then I move on to attempting to import the old database!


#2

What did you set for the PHP version for your peaceeyota.com domain? PHP5? DH runs either MySQL 4.1 or 5.0, so you may have to change the dbtype to mysqli.


#3

That didn’t do it. It led to this:

Fatal error: Call to undefined function: mysqli_init() in /home/.tounces/peaceeyota/peaceeyota.org/Forum/includes/class_core.php on line 1030

I know my vBulletin forum ran on mysql5 and php5 on my old host. I came to DH because it was recommended because it worked well for vBulletin.

So I’m stuck with these #&##& database errors (I’ve run this on three different servers with no trouble - so I don’t know what the deal is here!).

Also, as I follow the instructions to import the backup of my old forum, I get error messages every time (see below). I’m about to chuck the whole project!! I spent all day dinging around with this.

Error
SQL query:

– /usr/local/nf/bin/mysqldump --force --quick --quote-names -h mysqlhost -u -p**** ####

– MySQL dump 8.22

– Host: mysqlhost Database: d60273847


– Server version 5.0.24a-log

– Table structure for table ‘access’

CREATE TABLE access (

userid int( 10 ) unsigned NOT NULL default ‘0’,
forumid smallint( 5 ) unsigned NOT NULL default ‘0’,
accessmask smallint( 5 ) unsigned NOT NULL default ‘0’,
PRIMARY KEY ( userid , forumid )
) ENGINE = MYISAM DEFAULT CHARSET = latin1;

MySQL said:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘---------------------------------------------------------
– Server version 5.0.’ at line 1


#4

Before you do anything else, you probably should edit your last post to remove that database username/password from public view! :open_mouth:

–rlparker


#5

Ack - I didn’t see it hiding in there!

Thanks for the heads up.


#6

Something is not right with that mysqli_init() function being missing.

You’re certain your domain is using PHP5, and have confirmed that via phpinfo() output, I assume?

Many are running vBulletin on DreamHost, so there is nothing inherent in the DreamHost environment that prevents it from running; there must be some configuration issue with your installation.

I’m a little confused about the snippet/screen dump you have included. Is the “-” what you are using to indicate the prompt?

What, exactly, are the first 5 lines of the actual query?

–rlparker


#7

Ok. Having read back through the thread, there are a couple of things that have probably contributed to things being “borken” on your transfer:

  1. From your first post:

[quote]// ****** MASTER DATABASE SERVER NAME AND PORT ******
// This is the hostname or IP address and port of the database server.
// If you are unsure of what to put here, leave the default values.
$config[‘MasterServer’][‘servername’] = ‘mysql.peaceeyota.[color=#CC0000]com[/color]’;
$config[‘MasterServer’][‘port’] = 3306;[/quote]
This is wrong! Note the [color=#CC0000]red[/color] - this should be “.org” - there is no “mysql.peaceeyota.com” host.

  1. Make sure of what version of PHP you are running on your domain. You can tell this by going in the panel to the Control Panel -> Domains -> Manage Domains screen and clicking the “Edit” link under the “Web Hosting” column for the peaceeyota.org domain, and see what is there on the resultant screen (look for either PHP 4.4.7 or PHP 5.2.x).

  2. Then, with this information in hand, set the “$config[‘Database’][‘dbtype’] = ‘mysql’;” line appropriately in the config.php file - I would try it first with “mysql”. I do not use vBulletin, and I always use MySQL for this setting and have no problems, though lensman may be right for this application.

  3. Re-check all your other config.php settings to make sure they are correct, and try to run the forum before you try to “import” the data from your old installation - only proceed if you have the forum itself operating.

  4. If it doesn’t run, that should be fixed before proceeding.

  5. If it does run, on to the import, but recalling your last post before you edited it, I think you were possibly using some erroneous parameters with your command line import.

At any rate - you will not be able to connect to the database correctly with that “.com” in the hostname - and that was what I was seeing when I tried to load your forum. that has to be fixed first, or other mucking about will not work and is likely to only confuse things further. :wink:

–rlparker


#8

Argh - so I can’t type straight!

I now have the forum running - now I’m working on re-installing the backup.

I’m working with vBulletin, and they think the problem is with the back-up file made from the old server.

If that doesn’t fix things, I’ll be back.

Thanks a million for your help! Amazing how such a little thing can cause a grown man to cry!


#9

Hey, that’s progress…and as for the “typo” - we have all done it at one time or another. :wink:

The vBulletin people are good folks, and I’m sure they can help get that export/import sorted.

If not, we’ll “visit” again! Good Luck! :slight_smile:

–rlparker


#10

I am working on vBulletin forum. It’s displaying error like “Fatal error: Call to undefined function mysqli_init() in /var/www/forum/includes/class_core.php on line 1348” and my phpmyadmin extension is “mysqlnd”.