vBulletin installation problem

apps

#1

I’m new to Dreamhost so still figuring out the control panel (used to cpanel) and I’m running into problems installing vbulletin. I set up the database in my Dreamhost CP and I THINK I set up the values correctly in the config.php file. Here’s what I have:

****** DATABASE TYPE ******
This is the type of the database server on which your vBulletin database will be located.
Valid options are mysql and mysqli. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
$config[‘Database’][‘dbtype’] = ‘mysql’;

****** DATABASE NAME ******
This is the name of the database where your vBulletin will be located.
This must be created by your webhost.
$config[‘Database’][‘dbname’] = 'forums;

****** TABLE PREFIX ******
Prefix that your vBulletin tables have in the database.
$config[‘Database’][‘tableprefix’] = ‘’;

****** FORCE EMPTY SQL MODE ******
New versions of MySQL (4.1+) have introduced some behaviors that are
incompatible with vBulletin. Setting this value to “true” disables those
behaviors. You only need to modify this value if vBulletin recommends it.
$config[‘Database’][‘force_sql_mode’] = false;

****** MASTER DATABASE SERVER NAME AND PORT ******
This is the hostname or IP address and port of the database server.
If you are unsure of what to put here, leave the default values.
$config[‘MasterServer’][‘servername’] = "mysql.himchat.com’;
$config[‘MasterServer’][‘port’] = 3306;

****** MASTER DATABASE USERNAME & PASSWORD ******
This is the username and password you use to access MySQL.
These must be obtained through your webhost.
$config[‘MasterServer’][‘username’] = ‘’;
$config[‘MasterServer’][‘password’] = '
’;

But when I go to the forum itself to continue with the install I get this error:

Parse error: syntax error, unexpected T_STRING in /home/.montague/celticangel/himchat.com/forums/includes/config.php on line 34

Can anyone help? I’ve used vBulletin lots of times and never had an issue installing it. I really need to get this sorted because I’m moving hosts and I host official forums for several bands - all using vBulletin.

Thanks.


#2

I am not familiar with installing vbulletin, but a couple of things about your config file don’t look quite right to me…

I think there should be a closing quote on ‘forums’, like…

[color=#0000CC]$config[‘Database’][‘dbname’] = ‘forums’;[/color]

Looks like a typo here with the opening quote, should be…

[color=#0000CC]$config[‘MasterServer’][‘servername’] = ‘mysql.himchat.com’;[/color]

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#3

Those are just typos in the copying of the info into the post. They’re correct in the actual config file.


#4

No you were right. The ’ at the end of forums was missing. That fixed it. Thanks. I need more coffee before doing code lol


#5

Excellent, I am glad I could be of some assistance.

I know that feeling well :wink:

It’s amazing how the simplest errors are the hardest to track-down and cause the most frustration.

Good luck.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#6

Yes, we are all so accustomed to looking for big things, that the little things tend to be overlooked. I can’t tell you how many times I’ve run into this in running my 5 sites after my Webmaster went off on an indefinite hiatus. I moved everything over from GoDaddy to DreamHost in a few hours, including importing five databases for message boards and WordPress, and then had to do software updates, plug-in, updates, etc.

What a learning experience!

Peace,
Gene Steinberg
Co-Host, The Paracast
http://www.theparacast.com
[b]My DreamHost Promo Plan—Use the code: [color=#CC0000]ROCKS[b][/color]


#7

Well now I have another problem. Vbulletin is installed fine but I’m needing to import my old database. Can’t do it from phpmyadmin cuz the file is to big.

So I am attempting to do it via SSH - which I’ve never used before. I’m logged in and can see all my files but when I type the command into the command line and hit enter I just keep getting a message saying the host hasn’t answered and do I want to retry. Over and over and over. Here’s the command I’m typing as per the dreamhost wiki:

mysql -h mysql.example.com -uusername -ppassword newdbname < outfile.sql

And yes I’ve changed the necessary things for my info. At least the -h -u and -p parts. newdbname I’m assuming is my database name which is forums and then the < outfile.sql I’m assuming is my vbulletin.sql file. I’ve tried putting just that and I’ve tried putting the full path to the file in but I still get the host not answering thing.

What am I missing? Never used SSH before so god only knows what I’m doing wrong.