Vbulletin 4.0 errors

apps

#1

Last week this forum worked for years and then failure. I not IT person and I assume it failed when they upgraded my server… who knows.

I’ve upgraded from 4.3 to 4.05 and I still have the error. I’ve worked with vbullentin staff and they told me to remove all plugins…

this is what I get…
http://backyardgardener.com/forums/
but it should look like
http://www.backyardgardener.com/forums/forum.php

I’ve noticed my blog section is down and I can’t create a new thread because I would get this…
http://www.backyardgardener.com/forums/blog.php

I looked at my 3.8, 4.0 and 4.05 config.php files and they are all the same.

ANy thoughts why this failed?


#2

Looking into the debugging information on the error page, I see this:

[code]Database error in vBulletin :

mysql_connect(): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)
/home/yourusername/backyardgardener.com/forums/includes/class_core.php on line 313[/code]

This indicates that you don’t have your database connection information set properly.


#3

Thank you for the reply. I’ve reviewed my config.php 4.0 file and updated it to config.php 4.05… I thought it would work fine. I even checked my VB 3.8 config.php and they are all the same. I wonder what I need to revise or check in the dreamhost cpanel


#4

Make sure your database hostname is defined in the VBulletin config file.


#5

I’ve used the same names as defined in 3.8 config, 4.0 config and rolled it into 4.05 config. The error occurred in th 4.0 config and I thought the upgrade would fix it… nope.[hr]
Vbulletin team has stated:
Assuming the db info in your config.php file is correct, then this is a server issue. Please see this page for the causes of this error:

http://www.vbulletin.com/docs/html/cantconnect

TIme to read


#6

Check your pm man i’ll be able to help you