Using Catalyst on DH

software development

#1

I’m goin nuts here, I’ve used this page:

http://wiki.dreamhost.com/Catalyst
and
http://dev.catalystframework.org/wiki/Dreamhost

to install catalyst on my account. From what I can tell, it works fine. The listed CPAN modules are installed and current, and when I run the script/test_server.pl I’m able to see the Catalyst welcome page on port 3000.

Whenever I try to load the scripts in my browser though, I get “500 Internal Server Error”.

My permissions are fine, and catalyst is not at fault from what I can tell, as it runs fine on the included test server. Does anybody know what could be causing me to get 500s?

I know Catalyst isn’t offically supported, but I’ve searched google, the catalyst website, and even these forums and can’t find an answer to this problem.

Any help would be greatly appreciated. This is holding me back from learning to use perl for the web. Quite frustrating =/


#2

I’ve no idea how to solve your problem as i’ve never used catalyst.

However Google appears to have a lot of relevant suggestions

Cheers,
Karl

web design, development, pay per click marketing (PPC) & Search Engine Optimisation (SEO) by DigitalVibe


#3

Thanks. But unfortunately, most of those google results are for troubleshooting installation of Catalyst itself.

The problem wasn’t catalyst, but rather fastcgi. Turns out there’s FastCGI issues with sites hosted here on Apache2 servers. Support helped me out with that though. Gotta love those guys.

There was another issue though. After tailing my error logs a bit I discovered that some of my modules weren’t being seen.

For anybody who’s reading this and having similar issues, I solved mine by adding the following to myapp_cgi.pl and myapp_fastcgi.pl/dispatch.fcgi:

/home/[user]/site/perl/share/perl/5.8.4
/home/[user]/site/perl/lib/perl5

where [user] is your shell login, obviously.

I don’t know if that means the wiki isn’t accurate, or if it means something’s wrong with my environment. In any case, if you’re having that problem, give the above a shot.

Sheesh, what a headache. But finally, I can start working on a perl website. :smiley: :smiley: :smiley: