Username or password incorrect


#1

Hi. I am new to this on Dreamhost, although I have worked with web sites and FTPing files before. When I received my username and password from Dreamhost, I changed the password. I am trying to test the connection between my files on dreamweaver on my local PC, and Dreamhost. Whenever I try to connect to the remote host (Dreamhost), it says the login or password are incorrect. Can you help me?


#2

Make sure you’re using the User/Password for your FTP account, and not the one you use to log into the panel here.

-Scott


#3

I did use it. I used what was sent to me in the email when I signed up for DreamHost. I just have the trial version. Does that make a difference?

Thanks.


#4

If you’re on the trial version of full hosting, it shouldn’t make a difference. Did you use the panel to create a Fully Hosted Domain? Also, you can try the WebFTP option from the panel in Domains -> Manage Domains.

If all else fails, submit a ticket to Support.

-Scott


#5

I was finally able to connect using the username and password that Dreamhost sent me originally. I thought I changed the password, but apparently it didn’t take. I was able to connect and upload files using Filezilla.

However, the files must not be in the right directory or something, because the only thing that shows up on the web is the word Index, and then a list of my html files and their last modification date and file size. What folder or directory should they be in? I have a folder on your server with my web site name, but I created that myself.

I appreciate your help.
Thanks.


#6

Actually, from your description of the issue, it seems like you got the files in the right place, but just don’t have a properly named “index” file.

When a visitor accesses your website, the server checks the folder for an index file. Some examples of common index files are: index.htm, index.html, index.php, index.cgi, index.pl. The supported index files depend on the how the server is set up.

DreamHost’s servers are set to:

DirectoryIndex index.html index.shtml index.htm Index.html Index.htm Index.shtml default.htm Default.htm default.html Default.html default.shtml Default.shtml page1.html index.pl index.cgi index.php index.php3 index.phtml home.htm home.html home.shtml index.wml

As long as you name your “index” file any one of those things, it will work!

If you have two files with names from that list, Apache will show the one that shows up first (e.g. index.html will show up, even if you have an index.php file in the same directory).

You can change your own DirectoryIndex setting to be anything you’d like via an .htaccess file too!

If the server cannot find an index file, it will try to display an index of all the files within the current directory, however if this is disabled, the server will end up displaying a 403 forbidden error. Using .htaccess, you can use a completely different index file instead of the defaults listed above. To do this, insert the following line into an .htaccess file:

DirectoryIndex pagename.html

Change pagename.html to the page that you would like to use as the index file.

(Source http://wiki.dreamhost.com/KB_/Unix/_.htaccess_files#Alternative_Index_Files)

–rlparker
–DreamHost Tech Support