Uploads not showing in directory


#1

I created a domain yesterday and have got the hang of things, but for the life of me, I can’t get uploaded images via ftp to show.

I see them in the directories specified, under my domain login and made sure to put them in right place, so that they are accessible, but when I link to them, they do not show up.

Any help is truly appreciated.

Thanks


#2

Two things to check: make sure you are using the right user. Go to “manage domains” in the panel and check in the “web hosting” column to see if the ftp/sftp/shell user that you are using matches the domain.

Second is the path:
/home/USER/DOMAINNAME.COM/file.jpg would be mapped at http://DOMAINNAME.COM/file.jpg

Note:
USER = your ftp/sftp/shell user name
DOMAINNAME.COM = your “fully hosted” domain name.

Remember case is significant in the path.


#3

I have the file in http://domainname/images/file.jpg.

It showed up for 2 seconds, I could link to it, then it disappeared again.


#4

Not sure how you are using the image, but is hot linking disabled and is that the issue? http://wiki.dreamhost.com/Preventing_hotlinking


#5

No, I haven’t messed with any of the hot linking settings.

Are uploads instantaneous?


#6

Try forcing a refresh in your browser with ctrl-f5 and/or try a different browser. It’s odd you can see it for 2 seconds but then can’t.


#7

I must be doing something wrong with the ftp transfer. But for the life of me I can’t figure out what.


#8

FTP uploads are instantaneous. Another thing just might be a difference in capitalization: File.jpg is not file.jpg


#9

When you type in your browser e.g. http://domainname/images/file.jpg does the image show?
If yes all is correctly uploaded, but you might have additional codes in your html.

Also maybe you have you browser set for not showing images.

If you give us the URL it will be much easier for us to help you.


#10

your links are incorrect. try relative paths.