Uploads failing/No resume


#1

I’m trying to upload some large files to my webspace, but the transfers keep failing and I don’t appear to be able to resume the transfer from where it dropped off. Part of the problem appears to be ‘550 SIZE: Operation not permitted’ when it checks to see if the file being uploaded is smaller/equal/bigger than the file already in place. It’s supposed to resume if the file on the website is smaller than the file being uploaded, but when this fails it just starts transferring from the beginning. Does anyone have any ideas as far as getting resuming to work?


#2

how are you uploading your files?


#3

I’m using SmartFTP, connecting to my host and then placing the files I want to upload into the global queue. The reason the transfers are interrupted is attributed, in the logs, to the ‘Server closing connection.’ I’ve tried both Active and Passive modes and while active seems to allow faster transfer speeds it still fails and won’t resume.


#4

The same thing is happening to me, and I probably wasted several gigs up my upstream bandwidth before I noticed what was happening. Still isnt working.


#5

The same.

The FTP server is a sick!


#6

I’m having the same problem. I put in a trouble ticket almost 24 hours ago about it, so hopefully they know about it now (have received no response yet. I don’t know if this is normal, this is my first trouble ticket in my almost a year here, which is a good thing :slight_smile: ).

It’s a little aggravating, I’ve been attempting to upload five files totalling well over a gig since yesterday afternoon, and have finally managed four of them, but the fifth keeps bombing out.


#7

My ticket was answered and they suggested trying a different ftp client.
Are you all using SmartFTP? I’ve moved to CuteFTP and although I don’t like the interface nearly as much it is at least able to resume correctly on the DreamHost servers, and I’ve had no problems uploading the rest of my data. I will probably only use it for uploading things to DH. Anyway, the problem seems to be SmartFTP is using a method of resuming that the servers just don’t support and it seems likely that it would be the case for most other people as well. Support said they had “used Filezilla, CuteFTp and Dreamweaver” without issue, so you could try any of those.

Good luck, hope you get your problems sorted.


#8

No, I’ve never used SmartFTP. I’ve been using WS-FTP Pro for years with no problems anywhere, and at Dreamhost since last September with no problems until a few days ago. I have also tried uploading using GetRight Pro with no success. Both programs worked until last week. I have reset my modem to get a new DSL connection, and I have successfully transferred files to people using AOL instant messenger (something I would normally avoid doing). I even uploaded some fairly large files to Yousendit without a hitch, so it’s not my end that’s the problem. I gave one file to a friend to try uploading to his website, also located at Dreamhost but on a different machine, and that also failed. The problem is with Dreamhost, not with us, and not with our FTP client.

I have been trying for two days now to upload five files totalling around 1.3gig, each one failed at least twice, the four smaller ones eventually uploaded, but the largest 400mb+ one has failed five or six times now, sometimes an hour or two into the upload. And now I have two more files, 600mb and 700mb I need to upload. What is the use of all the space and bandwidth they give us now if we can’t use it? I’m feeling bad, too, because I just last week recommended Dreamhost to a friend who signed up, pre-paying for two years. At least her website mostly consists of html and small image files that she’ll have no problem (hopefully) uploading.


#9

I too am having the EXACT same problems! I’ve also noticed that a couple months ago I was able to upload my 200-300mb files to the DH server no problem, but just recently (last week) I noticed it is not working and I am using FileZilla, one of their preferred FTP clients. I too am convinced it’s not a problem on my end, but something with DreamHost, something must have changed.

I submitted a support ticket today, I’ll keep this thread posted of any resolution… please do the same, thank you!


#10

Im using smartFTP v 1.5

My problem isnt realy with large files, but transfering alot of files. This is the error i get most of the time.

227 Entering Passive Mode (64,111,105,51,228,170).
Opening data connection to 64.111.105.51 Port: 58538
STOR main.php
An established connection was aborted by the software in your host machine.
Server closed connection
Transfer failed.


#11

I am having FTP issues as well. Just using I.E. to upload but and having sporadic issues uploading larger files. I was able to upload a 240MB file overnight but just now I repeatedly tried to upload a 200MB file and it errors/times out. Maybe someone can referance this thread if they put in a trouble ticket for it so they can see mulitple people having issues.


#12

Yup, I’m getting dropped ftp connections constantly. There seems to be no real rhyme or reason. I also noticed that when I ftp a file to the server the last modified date is chenged to the time that it was ftp’d – that is not normal behavior.

I’m a new DH user, and this is leaving a bad taste in my mouth, fast!


#13

We have heard several reports of these FTP problems and have been looking into it. We just made a configuration change today that we believe may help. Let us know if you see any improvements.

  • Dallas
  • DreamHost Head Honcho/Founder

#14

Yep, another report! For the last few days I was hitting a limit of 20-25MB, sometimes timing out earlier. Today, I can’t get 3MB to upload.

I’ve tried Fetch, Cyberduck and BulletProof FTP. I’ve tried from home (comcast), the college where I teach and from Panera and haven’t had luck, so I know it’s not my service or my FTP program.

I’ve also been able to successfully upload large files this morning to another server hosted elsewhere, so it’s not my ISP or preferences or FTP client.

It’s really important that I get these files uploaded by today or tomorrow. Please help.

Thanks!
Michele


#15

Okay! This should be all fixed!

Here’s what was happening… for some reason (this is still not determined) our system has been reconfiguring our ftp server configuration file a LOT on most servers… like every few minutes. It SHOULD only be doing this when somebody messes with anonymous ftp settings (which is pretty infrequently) but something unrelated seems to be scheduling it.

Anyway, these changes would then schedule an ftp restart on the server, which would drop all current connections! And since this was happening every few minutes, big file uploads couldn’t finish.

For now we’ve fixed it by changing those restarts to just reloads, which re-read the configuration file but don’t drop any ftp connections. In woody (the older version of debian) apparently a restart wouldn’t drop connections… but on machines upgraded to sarge it now does.

Now we’re going to try and figure out why it’s reloading so much when it really shouldn’t need to in the first place!

But nonetheless, changing the restarts to reloads should have fixed the problem for good!

josh!