Uploading large file with PHP Shared Vs PS

software development

#1

Ok, this is kind of strange.

I have a shared server and have been able to upload files approx. 50 megs in size with no problems.

I took the dive and got a VPS account and have changed my php.ini file to match the one on my shared box… now for some reason I can not upload files around 50 megs.

My max upload and post size is set to 100M for the time being just trying to get this straightened out.

Any ideas?

Update: I just tested a 40 meg file and it worked but 43 megs did not…

I appreciate any help you may be able to provide!


#2

I tried to edit my previous post but am past the 360 min time frame.

Anyway some additional updates:

I’ve set my php.ini to some more extreme values for testing purposes and also have tried setting an .htaccess file in both the folder where the file with reside as well as where the script executes to see if either of these would work. The settings are below.

php.ini
memory_limit: 200M
max_execution_time: 1000
max_input_time: 1000
upload_max_filesize: 100M
post_max_size: 200M

.htaccess
LimitRequestBody 102400000

Still not working for me…
The part of the handler script that fails is

!is_uploaded_file($_FILES['photoupload']['tmp_name']){ echo "error"; }

which leads me to believe it has something to do with http post but, I can’t be positive on that and the identical script, as I said, works perfectly on the shared server.