Uploaded images not displaying on WP site


#1

All of the sudden, my Dreamhosted blog (www.aburdick.com/silvarerum) is no longer displaying images that I’ve uploaded – not even in the back-end WP interface – and I’m at a loss to figure out why. Any help would be most welcome!

I updated to Thesis 1.8.2 and Wordpress 3.2.1 back in July. I had no trouble uploading or displaying images immediately afterward; the problem seems to have begun in the past couple of weeks, though I’ve tweaked nothing behind the scenes. The issue occurs with new posts and with posts created months ago.

It’s a multisite WP setup, with two sites: www.aburdick.com and www.aburdick.com/silvarerum (my blog). Only the latter uses the Thesis theme. In the WP settings, the Upload Path for the latter is

wp-content/blogs.dir/7/files

And the Fileupload URL is http://www.aburdick.com/silvarerum/files

If I create a new post and upload a new image, I see (via FTP) that the image does indeed get uploaded into the proper (wp-content/blogs.dir/7/files) folder. But the image doesn’t display in the WP interface or on the site itself, as it once did. Instead I get a “?” placeholder.

What’s mysterious is that these settings haven’t been changed since I set up the blog more than a year ago; I don’t know why the Fileupload URL would suddenly become a dead end. (For what it’s worth, my non-Thesis site – www.aburdick.com – uses the upload path “wp-content/uploads” and the Fileupload URL “http://www.aburdick.com/wp-content/uploads” and has no trouble displaying images.) And again, this wasn’t a problem in the couple of weeks after I upgraded both WP and Thesis; it seems to have begun more recently.

Any idea what might be going on? I confess I know nothing about programming, .php, or what have you, so … explain/advise slowly, please! Many thanks …


#2

For anyone with similar troubles, the wonderfully patient and responsive Dreamhost tech folks offered the following fix, which seems to work:

"In your .htaccess file, there needs to be a rewrite rule that sends all image requests to a file that can tell which of your blogs you are sending too. Here are the lines I added:

#upload files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+)
wp-includes/ms-files.php?file=$2 [L]