Uploaded .htaccess, to get around 7MB php/WordPress upload limit. Crash. Bang. Uh oh

wordpress

#1

Let me preface by saying that I am a total noob when it comes to PHP and .htaccess and PHP.ini and all of that.

That being said, I would appreciate someone’s help if someone can help and I am willing to compensate for time if needed.

But let me be clear, I am not looking for someone to just post in on this and say, “Well, just read the Dreamhost support wiki. It’s pretty straightforward.”

Not to me it’s not (noob!). So if that’s your angle when you read this (ie - you don’t really have time to help), that’s cool and I understand it, but please don’t waste both our times.

Now, let me lay it all out. Here’s exactly what I did.

Earlier this evening I was trying to go into my WordPress admin panel for my domain ‘wecantwait.in

I am currently on the Dreamhost VPS plan, and that domain runs a WordPress theme purchased from Themeforest called ‘Rebirth’. The site itself is for a client (a church to be precise).

My goal was to try and fix something that has always caused a lot of drama with this client, because they often have audio files (sermons / music / etc) that are over the 7MB file size limit in PHP/WordPress for uploads, and then we can’t upload them into the WordPress Sermon plugin, etc… and all manner of shennanigans and audio downsampling/conversion has to take place, blah, blah. sooo…

I set out to try and fix this problem.

At first I looked online for a solution (Googled it) and came across several articles all saying the same thing… that to get around this limit you either have to…

A) Alter the PHP.ini file…

…OR…

B) Alter the .htaccess file for that particular domain

…in order to expand the upload file size limit.

So I tried to look up these topics in the Dreamhost support wiki, but honestly, I don’t have the background to understand doing what they said to do in the wiki (many of you are laughing at me right now… and honestly I probably deserve it!).

On top of this, when I went searching to find PHP.ini (I use CoreFTP as my FTP client to login), I could not see it anywhere. In fact, all I ever see when I login via CoreFTP is a long list of all my domain folders (I have about 30 of them). I never see any folder directory path like /home/username/ or anything like that, so it really puzzled me because the wiki had said something about seeing that sort of path/structure.

But, being foolish and undaunted, I decided to go looking for the .htaccess file at the root of my ‘wecantwait.in’ directory anyway, with high hopes of getting something done (even if it turned out to weed-whacking my site right into the dirt…)

Browsing it (my ‘wecantwait.in’ folder) in CoreFTP, I could not even see one there (an .htaccess file). It appeared as if none existed. Or if it did, I could not see it in the list of files at the root of this folder anywhere (hidden maybe?)

In any case, what I did then was incredibly foolish. I followed the advice in one of the internet articles and simply created a new .htaccess file in Notepad - no word wrap, saved under the ‘All file’ setting, with no file extension, and then uploaded it via ASCII (not in binary or mixed mode) to the root of my ‘wecantwait.in’ domain folder using my snazzy CoreFTP client.

It uploaded in a heartbeat. There as no prompt that anything was being overwritten or anything.

So then I went to load ‘wecantwait.in’.

The home page would load,… but NONE of the other pages would load anymore. :frowning: All of them gave me 404 errors.

I freaked, swore, and then calmed down,… and immediately went into my WordPress cPanel and tried to re-establish permalinks, which sometimes has an effect (with some of these commercial themes) of re-estblishing permissions that might have been altered somehow by another event,… say some noob (me) and his retarded Don Quixote .htaccess quest for the holy fail.

Fortunately, this educated guess was right, and the pages all came back after forcing a permalink request from the WordPress cPanel. (sigh of relief - site was back up)…

But then there was the question still,… about the file uploads. The 7MB file size limit. how to get around it.

I chatted with Dreamshot support, but basically, after 30 minutes of going back and forth, the guy told me that they are not allowed to help me with this (specifically, doing anything with PHP.ini). :frowning: and referred me to the wiki. Again. (might as well hand me the loaded gun again, chap)

I was like,… “Dude. I’m a noob. I went to the wiki. I looked it up using the big G. I followed some guy’s article. And I promptly trashed my site. That’s why I am calling you! For help?”

But no go. He said it was against policy. And he could lose his job. Okay. I get it. Don’t want that.

But basically, the last thing he did was to refer me here also, to see if anyone here could help. And I gotta tell you, a lot of threads here are way, WAY above my head… and honestly, I think one of the worst things a noob can do, is to try and learn some new process or concept using a live client site. I am interested in all of the technical concepts at work here,… but to be honest, in the short term,… what I am more interested in is finding someone who can step in here and provide me with a nice, neat, exact, little cheat (complete with screenshots and all) as to how to go about altering PHP.ini to get around the file size limit.

I don’t think the .htaccess route is going to work so well, as it already trashed my site once, so I’d like to steer clear of it if possible. Call it irrationale fear. Superstition. Noobish ignorance. Whatever. I just don’t want to push my luck with the permalink magic bullet fix again.

So that’s what I need, if anyone in here feel up to the task of outlining this for me and wants some beer money in return, please, please… DM me or email me at
g i v e i t l e g s at g m a i l d o t c o m

Many thanks all.

Cheers!


#2

The php.ini file is not available via FTP so you would need to create a shell user from within your panel or change your existing user from an FTP user to a shell user if it is not already set that way.

If I could first ask, what is the PHP version you are running on your domain, PHP 5.2 or PHP 5.3? You can find this also in your panel in the manage domains section. Just click “edit” link in the web hosting column for your domain and on the next page you will see a drop down box with something like “PHP 5.2.x FastCGI”.


#3

See link below.


#4

As a noob also can I just ask why in God’s name (pun kind of intended but not in a bad way >:) ) would you want to upload 7 meg files of audio onto your own server? I mean why wouldn’t you just do something like upload them to youtube and then make your church’s site have a redirect to the youtube? (Or something similar as below link…)
http://www.google.com/search?client=safari&rls=en&q=audio+hosting+sites&ie=UTF-8&oe=UTF-8
Curious minds…
'meist