Upload Permissions - suddenly it does not work

wordpress

#1

I have a working wordpress site on dreamhost, which has suddenly developed a permissions problem. If I try to upload images or any files, I get the following error:

“Unable to create directory wp-content/uploads/2015/03. Is its parent directory writable by the server?”

This is a very new problem, because I can see the direct “wp-content/uploads/2015/02” in the file system, so the ability of wordpress to make new directories seems to have died this month…

Suggestions?


#2

Note This issue has been resolved …


#3

How was it resolved? I am having the same issue.


#4

I am having the same issue, how did you get this resolved?


#5

Are you using an older version of WordPress? If so, you should update and that issue should resolve itself.
[hr]
If not, ftp to wp-content and verify that the permissions on it and all subdirectories is set to 755.

Note: If you google this, you will find a lot of people saying to set permissions on that directory to 777. This is inherently risky as 777 leaves that directory readable and writeable by everyone, thus making you vulnerable to security issues.


#6

I did update wordpress hoping this issue would be resolved and it is still not working, I am still receiving the same message. I’m not uploading the images any differently from my other blogs, so I’m not sure what the issue is?


#7

Okay, one more thing to try:

Go to http://www.example.com/wp-admin/options.php and scroll to “upload_url_path”. That field should be empty.