Upload Maximum File Size, Help!


#1

Hi,

When I try to upload files to my server the files can’t be over 7-8mb. I know these are the standards for Dreamhost but it’s just too less for my website. I’ve read a lot of topics about this subject and everyone says you should modify a php.ini file as you can read here: http://wiki.dreamhost.com/index.php/PHP.ini.

I asked the dreamhost customer service about they are not allowed to help.

But I don’t get it. I don’t know anything about where I can find the default php.ini file or how to modify it.
So if anyone can help me with this it would be much appreciated. I’ll pay you for your help if you want.

Kind regards,

Joost


#2

Follow those wiki instructions and change post_max_size and upload_max_filesize to the size you need. Just make sure you replace “example.com” with your actual domain.

If you don’t already have a .htaccess file, you’ll have to create one.

-Scott


#3

Thanks for your reply.
I don’t understand what to do at step 2.
It’s no problem for me to create a cgi-bin folder but what do they mean by ‘Copy the default php.ini file’. Where can I find it and how to modify it. I know it’s a newbie question but I would be really glad if someone of you could help me out…


#4

Those grey boxes are the commands you need to run via shell. As I read the wiki, it doesn’t explain about logging into command line:

http://wiki.dreamhost.com/SSH

-Scott


#5

Thanks again. I typed in every line that was on this page: http://wiki.dreamhost.com/PHP.ini, it created the cgi-bin with the php.ini and the php-wrapper.cgi. I modified the 2 lines post_max_size and upload_max_filesize to 100M. Then I tried to upload a file of 16mb but it’s still nowhere to be found.

The only thing I didn’t do yet is setting up the .htaccess file. When I tried adding these 2 lines:

Action php-cgi /cgi-bin/php-wrapper.cgi
Action php5-cgi /cgi-bin/php-wrapper.cgi

to my .htaccess I got a 500 error on my website.
Could you help me one more time please. Thanks.

Joost


#6

I’ve not experimented with this particular approach, but here’s what’s in my .htaccess:

Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php-wrapper.cgi

Try those instead. Even throw in the php5 line as well for good (or bad) measure.

-Scott


#7

It still doesn’t work when I try to add other lines to my .htaccess. I tried to follow this tutorial: http://www.activecollab.com/forums/topic/1507/ but I can’t get it to work. I think it’s weird that the PHP.ini is modified to 100M and when I go to my info.php page it says 7M. How is that possible?

Joost


#8

It’s possible because the wrapper is not being called. Can you just post your entire .htaccess file with any sensitive info X’d out?

-Scott


#9

Thank you very much for your help Scott, it works now :D. It took me a while but with your guidance it was a lot easier. I really appreciate it.

I had to add a line to my .htaccess file. That did the trick.

Thanks again.

Joost


#10

Cool. I’m glad this new method works. It’s much simpler than the old method.

-Scott


#11

Yoshi, can you post what you ultimately had in your .htaccess file? I’ve followed the instructions in the Wiki for creating my own php.ini file (so I can modify my post_max_size and upload_max_filesize), but it doesn’t seem to be taking effect, according to my php_info(); statement…