Upload Issues

wordpress

#1

Hello,

I am having issues uploading photos in Wordpress. if I upload multiple photos, the upload process will freeze meaning it will stop at one photo at 100% and that’s it and/or throw out a “HTTP Error”.

I have to upload the files one by one and I then have to refresh the window when I get to the third file cause it won’t upload, it will just freeze.

The image sizes are anywhere from 47kb to 280kb. I am using PHP 5.4.

Why is this?


#2

Have you tested what happens with no plugins turned on, and the default theme running?


#3

I am having the same issue!

It happens on both sites I have hosted with you so far.

What is the problem?


#4

Same question really. Have you tried without any plugins on, and using the default WP theme?

Since the problem doesn’t happen for everyone, it’s good to start with the basics.


#5

I’m also having the same issue (multi-uploads of small files)

Here’s what I’ve already tried:

  • Disabled plugins, changed to WP “2013” theme
  • Modify phprc to increase memory limit, per DH support staff suggestion
  • Modify htaccess file to bypass modsecurity on async_upload.php file requests

#6

dexterlo - What’s your domain/ticket number?

The normal causes for this:

  1. Out of space in /tmp
  2. Images are too big
  3. Memory issues
  4. WP is being a prat

I hate #4


#7

I’ve been having this same issue ever since I switched from Bluehost to Dreamhost.

I’ve done everything on my end that I can, plugins, reinstall, change theme, change htaccess file, etc. None of it works.

Additionally, the issue isn’t consistent. I upload the image once, get the HTTP Error, then I upload the file again and sometimes it’ll work, sometimes it won’t. It never lasts more than 3 times, though. Eventually it always uploads, but it can get really time consuming.


#8

What size of images are these? Does it always fail on one type but not the other? Have you checked from other computers?

I know it’s weird, and it’s a headache to debug because it’s like the old “An error has occurred” messages you’d get on a mac. gaaah


#9

A client of mine was having a similar issue. After talking with them, it turns out there were two things going on:

there were travelling in Europe, so their internet connection was changing. Some places it was slow, other places it was speedier…this threw me off a bit until I thought about it, since sometimes things would sort of work and other times it would not. the speed of their internet of course being the variable factor.

the other thing was that they were taking piles of huge-resolution photos, and then trying to load several of those monster-files at once. However, other times they would take smaller-resolution photos from their phones and upload them and have no problem.

Given those two things, and the fact that they did not have a grasp on photo-sizes and resolutions…they were just frustrated when things were not “working”

I had to give a lengthy tutorial on how to re-size photos to more web-friendly proportions. Once they grasped the concept, they no longer had any problems.

Not that this is what the two here were dealing with, but just as a first-thought.


#10

My domain is dexterlo.com (ticket #6030743)

The images are around 200K. For now, switching to non-fast-cgi seems to work. But… I thought FastCGI 5.3 was the recommended setup?