Upload file size limit


#1

i know this has been a common question on these boards and i’ve tried to do as much homework as possible before posting here; to this effect i’ve already followed the instructions on the KB about setting up my own (local) php.ini

the problem is, my uploading script (php) is still running into a 16mb limit somewhere.

as it stands, these are some of the settings in my modified php.ini

post_max_size = 10000M
upload_max_filesize = 10000M

these are defaults i have also tried modifying (shown in brackets) but this did not seem to remedy the problem so they are currently back to default

max_execution_time = 30 (3600)
max_input_time = 60 (3600)
memory_limit = 90M (180M)

im not very experienced in any of this, for a start i’m actually unsure what eg. 100M; equates to in kb or mb?

thanks in advance.

tom.


#2

First, please check via a phpinfo() run that your new configuration is actually being read and is in effect.

Often folks get the changes made, but don’t manage to properly get their configuration set-up to use them; you can see this via phpinfo(). :wink:

–rlparker


#3

thanks for the quick response.

yes the configuration is exactly as posted above when viewed via phpinfo()


#4

Then it would seem that the limit you’re hitting now is set by the particular software you’re using to upload with. What are you using to upload with - someone here is probably familiar with it and can help you figure out where the setting is.

–Matttail
art.googlies.net - personal website


#5

i dont think it is. the script is found http://www.ecosmear.com/relay/

but it has a demo running here http://www.ecosmear.com/relay/demo/

and i am able to upload files in excess of 16mb to that server.

edit- i don’t know if this will help should anyone actually take a look at the script, but when using it to upload a file over 16mb, it will go through all the motions of uploading, eg the status bar progresses, the remaining time decreases, and my up speed it shown correctly. its when it actualy finishes the upload, ie it hits 99%, that it stops, or freezes.

(ps, what was the answer to my M-Mb question)

cheers,

tom.


#6

That sounds like it might be a memory issue…irrespective of how you set up PHP, DH only allows a certain amount of memory to be used, then their procwatch program kills the PHP program.

That is just a guess, though, and I could not look at the program code to investigate further, as the link to the code from the site you provided returns a “404” not found for the .zip file that contains the actual code…I couldn’t download it to take a look :frowning: .

Have you discussed this problem with the folks on the script’s forum? They might have a better chance of recognizing the symptoms of the problem you are having and be better able to suggest a fix than we can (we can’t even see the code!)

–rlparker


#7

hmm… thats odd, i just went back to the website and had no problems accessing the download again. (but just in case, i’ve uploaded the relayb1-071706.zip to youendit if you wanted to take a look. http://download.yousendit.com/E4D49F180F637ED6)

with respect to the forums, they have a wiki (linked on the main page), but so far its not yielded any success…

if it were DH terminating the process, is there another way to get round this?

edit- on a side note, if you do manage to get a look at the script; i am getting this error when running ‘perl ./mysite.com/upload/upload.pl’

“Can’t locate conf.uploader in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at ./mysite.com/upload/upload.pl line 8.”


#8

::bump::

:slight_smile:


#9

I did grab the zip file (was now available) and took a very quick look at it…I don’t think it is even using PHP to do the upload…it appears the upload module is written in perl.

Unfortunately, I have not looked at the programs in depth - but I doubt the problem is related to PHP…I suspect it is a permission issue, or something wrong with the perl code or the way php invokes it in the DH environment.

–rlparker


#10

Don’t forget that there is an approximately 100M total process size limit. As far as I know this applies on a per user basis, not application.

Exceeding this limit may cause the “Reaper” (process killer) to do its dirty work to ensure the server keeps running for all users.

Wholly - Use promo code WhollyMindless for full 97$ credit. Let me know if you want something else!


#11

when you say 100M, does this equate to 100Mb?

and the size of the ‘process’, does this change depending on the size of the file that is being uploaded?


#12

The 100M refers to the memory limit, in megabytes. Even DreamHosters creating custom PHP installations set upload limits based on this memory limit, because any process exceeding this limit will almost certainly be killed.


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#13

well after all that i finally found my answer here

http://wiki.dreamhost.com/Relay (read the last line)

cant believe ive never seen that page before :slap:

so it seems that dreamhost impost a (8mb memory limit) 16mb limit on uploads regardless of custom php.ini… damn


#14

Nope. If you properly modify the php.ini memory limits, you can get anywhere from 1meg to 90meg uploads. The problem is your userspace limits (ie. how much memory in total your using) and procwatch - which will eat any and all processes it feels are being abusive. That is perhaps your problem more so than a memory limit.


Chips N Cheese - Custom PHP installs and the like!


#15

hmm, well to quote the dh wiki

“Please note that due to the 8M memory_limit imposed by Dreamhost (regardless of custom php.ini),you will be limited to 16MB uploads, and the download cart will fail to zip large files as well.”

and 16mb is exactly the point in which im hitting a barrier. ive modified my php.ini according to the instructions on the wiki, so whats going wrong?

ideally i need (or would like) a way of being able to upload files anywhere up to 300mb in size, but im currently getting the feeling that this is only possible through ftp…


#16

Well, if you want to upload files over 90meg in size, then you need to find a non-php based script to do so. Custom PHP installs, including custom PHP.ini’s (unless they’ve changed their PHP builds to reflect) of the past, allow you a maximum of around 90megs absolute maximum upload for a file. I’ve not been able to hit anything higher than that.

So I’d suggest either asking around here or doing a google search on a Perl-based script or such that does something similar to what you want in this case.


Chips N Cheese - Custom PHP installs and the like!


#17

Check out Uber-uploader. It works on DH (tested with PHP4 and PHP5) with no modifications at all to PHP (uses pearl to do the uploading).

I have personally tested it and found it to work well with a 125MB file - I have no need for a web-based upload of even half that size.

For the life of me I can’t understand this…just out of curiosity, why would you even want to “upload” a file of this size via http? :open_mouth: .

–rlparker