Upgrading php on my private server


#1

Greetings,

I’m trying to upgrade my private server from php 5.2 to php 5.3. I ran

sudo apt-get install libapache2-mod-php5 

as an admin user, which is supposed to be 5.3 (http://packages.debian.org/sid/php5) but my phpinfo.php still says 5.2.

Has anyone else ran into this?

Thanks
Doug

ps: on a slightly related note, I tried compiling php directly but had an issue with openssl, and DH told me I couldn’t compile on a PS… tear


#2

You will need to compile your own PHP CGI binary to get PHP 5.3. See http://wiki.dreamhost.com/Advanced_PHP_configuration for details.

libapache2-mod-php5 is not used on our systems, and would only install PHP 5.2.6 for mod_php even if it were used, because we’re using the stable Lenny release, not the unstable Sid release. ( http://packages.debian.org/lenny/php5 )


#3

ok thanks!

I’m not a huge fan of having to symlink every site to that new php5 directory… but I’ll deal.

Problem, when I get to the part of modifying the htaccess file, I made it only be the following

Options +ExecCGI
AddHandler php5-fastcgi .php
Action php5-fastcgi php5/php5-wrapper.fcgi

(changed /php5/php5-wrapper.fcgi to php5/…)

I get:

400 Bad Request
Your browser sent a request that this server could not understand.

This happened with other htaccess lines for rewrite, so I tried it with just the cgi stuff and it still does it.

Thoughts?