Upgrading gem to 1.3.6


#1

so i have been struggling to upgrade gem from 1.3.5 to 1.3.6.

i installed 1.3.6 from rubyforge

RubyGems installed the following executables:
/home/USERNAME/.gems/bin/gem1.8

however, immediately following, it shows that it is 1.3.5:

$ ~/.gems/bin/gem1.8 -v
1.3.5

regardless, i attempted…
$ ~/.gems/bin/gem1.8 update --system

Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
ERROR: While executing gem … (Errno::EACCES)
Permission denied - /usr/local/lib/site_ruby/1.8/rubygems/uninstaller.rb

does anyone have any ideas here? i have exhausted all of mine. thanks!


#2

Did you export all the required paths correctly?

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

yes.

export GEM_HOME="$HOME/.gems"
export GEM_PATH="$GEM_HOME:/usr/lib/ruby/gems/1.8"
export PATH="$GEM_HOME/bin:/usr/lib/ruby/gems/1.8/bin:/usr/local/php5/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games"