Upgrading from old media wiki version


#1

Hi everyone,

I’m trying to update mediawiki from a very old version 1.16. It was installed as a one-click install, so I tried updating it using that, but I got an email back:

We were unable to set up Mediawiki as requested at:
http://www.panamath.org/wiki/

The problem was Invalid DB: my_database could not be found on your account!

Please correct this and go to our web panel and re-submit your
Mediawiki upgrade request.

Does anyone know how to get around this?

Thanks!

note: my_database does not exist anywhere in phpmyadmin or dreamhost and I can’t find a trace of it anywhere–I believe it may be an old database


#2

Open up the LocalSettings.php file in your wiki (you may have to download it first). That will tell you the database name and MySQL host.


#3

Yeah, I actually managed to get around it by creating my_database and copying my wiki into it. I think the one with the original one must have been renamed/deleted. However, now when I try to do the one-click upgrade, it get this error:

The problem was Invalid DB User: your database my_database has no user and we couldn’t safely update!

I’m not sure what “user” it refers to? Because there are users in the “user” table of the database. And I have a user with access to it on Dreamhost


#4

Its probably asking for the MySQL user. Look in the LocalSettings.php file for the $wgDBuser and $wgDBpassword variables, and set them to your MySQL user and the password for the MySQL user.


#5

Okay I realized I had $wgDBname set to the old database still, but even after setting it to my_database I still get the error. And I have $wgDBuser and $wgDBpassword set as that user was able to access the old database and I have granted the same permissions to my_database via Dreamhost. ’

One weird thing I noticed is that for my_database on DreamHost under ‘MySQL Databases’ it says (Size Unavailable) where for all the other databases including the old one it says the database’s size in parentheses. What’s the cause of this?


#6

I resolved the issue at long last.

I did have a user, but it was a different user than the original now-nonexistent one used to install MediaWiki. I contacted DreamHost and they fixed the user in the upgrade script to match the current user I have for the DB. I suspect that this was the same problem with the original error with the DB not being found. It would have been much easier just to contact DreamHost and have them fix the upgrade script so that my_database was used instead of a now-nonexistent one used 5 years ago.