Upgrade to Debian 3.1 (Sarge) killed my movetype


#1

Running movable type 2.6 on two websites hosted by dreamhost using berkelydb not mysql.

It appears the Debian upgrade killed my 2 sites; comments are down as is any ability to login. happily the content remains.

Movabletype covers this problem in this post:

http://www.sixapart.com/movabletype/docs/mtmanual_troubleshooting.html#i changed hosts, and now i can’t log in to movable type.

Basically, I have to go through every file in the db folder of each site and do this:

-START QUOTE-
Now that you have determined which db_dump program to use (either db_dump or db_dump185), you can dump all of the data from your old DBM files and load it into new versions of those files. To do that, try the following (substitute db_dump185 instead of db_dump, if necessary):
$ db_dump -f author.db.data author.db
$ mv author.db author.db.old
$ db_load -f author.db.data author.db
$ chmod 666 author.db

You will need to run these four commands for each file in your db directory whose name ends in .db or .idx. After you have done so, you’re done, and Movable Type should now work.
-END QUOTE-

This really sucks. Anyone know if there is a faster workaround here? Anyone been in touch with Dreamhost support yet about it?


#2

I can’t log in to Movable Type on either of my sites either; should I assume this is why? Honestly, I don’t know enough about this stuff to understand the instructions you just gave from the Movable Type forums. Arrgh!


#3

Thoes the instructiosn from MT, hmm? They’ve changed abit. Just make a backup of all your database files first! Then you should be able to fun the sb dump script on *.db do “db_dump -f *.db” (I’m pretty sure that’s right)

Basically you just need to upgrade all of your database files to the new verion of Berkeley. Just to explain what happened, is when the sarge upgrade went through on your server, berkeley got upgrade. And this is a MAJOR downfal of erkeley, they almost allways change the structure of the database when you upgrade. So anytime this happen, you’re going to have to upgrade your database.

So berkeley got upgraded, and now it’s trying to find a structure in your datbase files that doesn’t exist - the result? no database. Comments and the entire backend are down. All of your content is there becuase Mt actually creates html archive pages.

Now, once you’ve got access to mt.cgi back, and your site is working, do your self a favor. convert to mysql! you’ve got acces to the database, and there needn’t be a nitch in yoru site when you switch over. And it will save you the problem of having to upgrade your database as you have to now.

Also, and I found this one out the hard way, if you should switch to an other host that is running an older version of Berkeley - you’re out of luck. At least a year ago when I had this problem, there was no downgrade utility. I personally was stuck manually importing my entries from the archive pages back into mt - and I had to totally recreate my page design.

Anyways, enough with my rambling. the instructions from MT used to tell you how to do the entire DB whole sale, and I’m pretty sure that *.db will work, but if anyone else here knows differently, please comment.

Hope this helps, and good luck.

-Matttail


#4

apollonia666, when you set up MT here, did you use the berkeley DB, or did you set up a mysql db?

If Berkeley, than the same will apply to you, if it’s mysql - then the issue is unrelated.

-Matttail


#5

Also, I ment to say this before - you should also upgrade to the latest version of MT. I think there’s been some security fixes since your version. But don’t worry about that till you get your install working again. :slight_smile:

-Matttail


#6

Honestly, I don’t know. I had a friend set it up for me because I found the installation directions for MT confusing and was afraid I’d mess it up.

When I emailed Dreamhost customer support about this new problem, they wrote back and told me I’d have to I need to run the following command line:

find . ( -name *.db -o -name *.idx ) -exec db4.3_upgrade {} ;

on all the files in this directory of my account:

/home/uffish/db

A friend who’s a bit more computer-savvy than I managed to log into my Unix shell and tried to do this, but got a “permission denied” error. They all have permissions set to 644, and as far as we can tell I don’t have the ability to change permissions for these files with my current login. I need to either have the permissions changed so I can run the command string myself, or have DreamHost run the string as a system administrator.

It’s now been a day and a half since I submitted another support request asking about this and I haven’t heard a peep back from Dreamhost. They’re usually fast to respond, so I imagine they’re probably having lots of problems right now with a jillion MT users submitting help requests. That doesn’t really lessen my frustration, of course.

Does anyone know what chmod command we’d try to change my permissions?

Somewhere else someone suggested that upgrading Movable Type would fix this. Anyone had any luck with that?


#7

as long as you loged in with the user who is excuting cgi (check in the panel > Domains > manage) then you should have access to do anything relating to your files with permissions at 644.

If you can’t excute any commands on the files, somehthign else has gone wonky with your files, and support will need to fix it.

Why dont’ you try upgrading a backup of one of your DB files with the command sigguested by MT’s instructions and see if you get the same error - that should prove where the problem lies.

If you want to try it anyways, you can CHMOD files two differnet ways. Normally a goof FTP client will let you do this - just right clikc on the file and find CHMOD or go to properties and chnage there. You can also CHMOD from teh command line, just type: “chmod 777 file.name”. do be sure to return any settings to their origional value if you should change them (though I’m pretty sure it won’t make a difference)or your stile will be vunerable to attacts and whatnot.

Hope this helps

-Matttail


#8

Thanks very much for the advice. I’m not quite sure what we were doing wrong before, but we managed to get logged in and run the command string – and I still can’t log in to MT! I wonder if something got corrupted somewhere during all this craziness. I’m totally flummoxed as to what we should try next. :frowning:


#9

from the command line, run this command on one of your DB files and see what you get:
“db4.3_verify file.name

Than paste the results into a message here.

-Matttail


#10

Help. I don’t know how to “run” these instructions. Can someone start at the beginning? Open what interface or program or page or file and then type this information?

Pitifully yours …


#11

that’s refering to telnet or ssh.

If you’re in windows you can use telnet - Start > Programs > accessories > Communications > Hyper Terminal.

Or download a nice ssh client like Putty.

Either way, you connect up to machine.dreamhost.com, where machine is the server you are hosted on. Then you’ll log in with the user/pass for that domain. Search the K-base for some more specific instructions.

-Matttail


#12

Thank you. I have tried to find this in my cpanel and in the knowledge base but I can’t. How do I find the name of the server I’m on?


#13

i’m having the same MT problem that everyone else seems to be having – and it happened immeditely after the upgrade – only i don’t use berkeley DB. i use MYSQL.

any suggestions for this? i don’t think the problem is only with berkeley. i run 2 blogs with MYSQL and i’m locked out of both of them.

should i just toss MT and then install an new version? will that actually solve the problem?


#14

Tossing MT and making a new install would fix the problem, but I really don’t think that’s called for. You’re simply not able to log in at all, and comments and other such things are broken? I’m not exactly sure what would cause this… I think your first step should be to contact support and ask if they have any insight into the matter.

MYSQL wasn’t efect by the sarge upgrade to your hosting machine, so it seems odd that you would loose database access, enless the permission or soemthign else got wonky with the mt.cfg and or the db pass file.

-Matttail


#15

well, I’ll be.

I was looking thorugh hte panel to try and figure out where that informaitn is now stored, and checked out the K-base. it says that all you need to connect with ssh is your domain.com. so just bring up putty, and type the address as show iwth your domain name. simple as pie!

-Matttail


#16

i don’t use comments, and nothing else appears to be broken. i just can’t login. i sent a message to support 1 1/2 days ago but haven’t heard back yet.

checked mt.cfg and the db pass file and didn’t see anything wrong with them as far as i could tell.


#17

I’ve been waiting two days, and they still have well over 400 support requests open. Don’t hold your breath.


#18

Hi, the following should work for most Dreamhost Movable Type users still on Berkeley DB.

  1. First, enable a Dreamhost FTP account that can access your space for shell (ie, telnet) access, if that hasn’t been done already. You can do this if you’re the main (ie, paying) account holder in the Dreamhost Panel by going to Users/Manage Users in the left navigation bar. Alternatively, get the main account holder, if you’re sharing space with someone else, to do the rest of this on your behalf.

  2. Wait half an hour to two hours for telnet access to be granted, if you needed to change that first.

  3. Windows comes with a basic telnet client, which is all you need for the rest. Type in “telnet [your domain here]” and supply your FTP (now also telnet) login and password.

  4. Use the command “cd” (change directory) to navigate to your database directory. For instance, if your directory is at [your domain here]/db, type “cd db”. You can confirm you are in the right directory using the command “ls” (list), which will list your files. When you are at the right directory, it will have a lot of *.db and *.idx files, which are the files you need to change.

  5. Type in: db4.3_upgrade *.db *.idx

  6. Go back to blogging.


#19

In case it matters to anyone else searching the forums, I found the machine names listed in the Users area next to each user.


#20

Holy crapoly. It worked. Thank you!