Upgrade Ruby?


Is there any way we can upgrade the Ruby version from 1.8.7 to 1.9.2, 1.9.3, or 2.0.0? I made my Rails app with the new hash style, so it’s a pain to change them back to normal, and perhaps the bigger concern is that Twitter bootstrap doesn’t work with the old version of Ruby… I also think that I can’t install Ruby myself on a shared server…

Is there a way to upgrade the Ruby version? If not, what should I use instead of Bootstrap? Are there similar stylers that work with 1.8.7?

Many thanks!


Wait, what? Twitter Bootstrap is a CSS / Javascript framework, not Ruby. It doesn’t require Ruby at all, let alone a specific version.


Hey, I read somewhere that it said that Bootstrap required ruby 1.9.x or higher. If it doesn’t require Ruby, then could you tell me what to do to get the Bootstrap styles to show up on Dreamhost? It works fine on localhost in development where I use ruby 2.0.0.


I’m not sure where you would have seen that. If you’re seeing issues with your Bootstrap-based theme applying on DreamHost, there’s probably some issue with the way you’re loading the CSS / Javascript files involved. It’s impossible to say for sure without seeing your site, though.


Hey Andrew, you are right. Using RVM on my local machine, I changed to Ruby 1.8.7 and created a test app, installed bootstrap-sass gem, and it DID work. However, when I change the RAILS_ENV to production, Bootstrap’s no longer loads, and it’s just an unstylized page. How should I load the css/js on Dreamhost? Also, when I run rake assets:precompile, nothing happens…

Off the top of your head, do you have any ideas as to why it doesn’t work?

Many thanks!


The bootstrap-sass gem is something separate from Bootstrap itself, and isn’t something I’m personally familiar with. It sounds as though it might be running into some sort of problem running the SASS compiler, but that’s just a guess.