Upgrade caused fatal error


#1

New to WP and when I upgraded Genesis I got 2 fatal error messages saying: Warning: require_once(/wp-content/themes/genesis/lib/init.php) [function.require-once]: failed to open stream: No such file or directory in /wp-content/themes/balance/functions.php on line 3

Fatal error: require_once() [function.require]: Failed opening required ‘/wp-content/themes/genesis/lib/init.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /wp-content/themes/balance/functions.php on line 3

I am unable to access my WP panel to uninstall the Balance theme. Should I delete it from my Dream Host panel? If so, how? I have located the file in my wp-content/themes/ but don’t see anything that will allow me to delete?

If I do delete the theme, will I lose my content. This site is new and I was about halfway through set up when this happened. I did not back up my files before the upgrade.
Thanks for any help :slight_smile:


#2

No, you won’t. WordPress stores its data in a MySQL database, not in php files. You may lose any modifications you made, if you edited theme files. (Which you really shouldn’t do; a child theme is the proper way to modify a theme.)