Updated .htaccess file and now site won't load

wordpress

#1

I’ve been trying to get my site rickguerra.com to go from http to https and I’m having the hardest time. I initially contacted dreamhost via chat and was given this link by the dreamhost representative saying I needed this plugin: https://wordpress.org/plugins/https-redirection/

So, I downloaded the plugin and I read the directions carefully and installed it. Shortly afterwards I went to refresh the site and it went to https://www.rickguerra.com, but then timed out giving me a “connection has timed out” error message.

I have Wordpress version 4.1 and “delicately” made changes to the .htaccess file as was instructed via the plugin the technician told me to install only to learn later it was a horrible mistake. I can’t get anything to work to get the site to load correctly now. After I noticed it not working I removed the https-redirection folder(directory) from the root rickguerra.com server and replaced the .htaccess file back with the original I still can’t access rickguerra.com/wp-admin. It’s become a very large problem for me and I quite frankly after 5 hours of researching am left with nothing else to look at…PLEASE HELP!

This site is critical to be running as it’s for an attorney and he has clients coming to it all the time. Desperately need attention as soon as possible! I’ll send you whatever files you need in order to help me sufficiently get this working.


#2

First, get the normal site working again. Use shell or FTP access to rename the .htaccess file to a different name, remove your changes, and get the original site working again. It is always easier to go from a working configuration to a non-working configuration rather than to try to find what you did wrong with the non-working configuration to get it back to working status again.

Take things one step at a time. Don’t try to do it all at once.

Then, create your SSL directory. Start with a simple html file such as this

testinghello world!

Get the page to show up with the https protocol. The SSL site directory needs to work before anything else will.

Then, copy your site into the SSL directory. Make sure that it works with https protocol before going on. Don’t forget the settings -> general page for the site address.

Then, and only then, go to the http site and add the widget to redirect traffic to the https site. This widget does a 401 redirect to the https site if you access the http site. IT IS NOT REQUIRED FOR HTTPS PROTOCOL. I regret that you were misinformed about the widget. You need to have SSL on your site working first.

If you don’t want two copies of the site, the create a sym link from the http location to the https location. The widget won’t do anything if the protocol is https. But, HTTP protocol sites are usually in a different directory than HTTPS because the Apache configuration is in two different sub-sections.