Unusual DNS not propagating?


#1

My client occasionally registers new domains at GoDaddy, then they ask me to host them at DH. Yesterday I created two new domains in DH, and after a bit of time I changed the three primary name servers for two domains from their default to NSn.DREAMHOST.COM.

One of the domains resolved within minutes and the DH default page from my account space displayed. But not for the other domain, which a day later still shows a Server Not Found error.

I saw this earlier yesterday, checked the nameserver entries, replaced them, and gave them a whole day to propagate. I’ve triple-checked the name of the domain, etc. The DNS simply isn’t resolving.

What’s my next diagnostic step?

Thanks!


#2

Same problem, set up new account a day and a half ago and still no DNS. Going to contact support now.

Edward


#3

Four days later here. Something is up. Did you get a helpful response? I’m probably going to try to reset DNS for the bad site back to GoDaddy, make sure it resolves, then try switching back to DH again. Thanks.


#4

Yes, I contacted support and the DNS was working in an hour or two. Obviously the automatic setup did not work. Does not leave me with much trust in Dreamhost. Tentatively planning to consolidate my sites on apisnetworks.com.

Part of the problem is the DH does not guarantee that the IP address will remain the same. As a result, you have to point your NS records to their name servers, rather than using external name servers (which your domain registrar probably provides) and pointing your A record to the web server. Come to think of it, this means you have to use DH for your mail server too (MX). Too much entrapment. I had trouble moving away from a free hosting server which required me to use their name servers because they set a very long TTL and I could not control it.

Good luck,

Edward


#5

There’s nothing that says you have to use DreamHost as your mail server if your domain’s hosted with us. There’s a whole section of our panel (Mail > Custom MX) that’ll let you set your own, as a matter of fact!


#6

Edward, thanks for the note, but yeah, we’re not quite on the same page…

I’ve been a customer of DH now for about 5 years, having been through some horror with other providers. If there is an issue in this specific area, it’s not chronic, not permanent, and certainly no reason to move to another provider. Note your own statement, that DH Support had things working within an hour or two after you reported it. Dude, that’s not bad at all considering typical non-DH Support response time and typical DNS propagation time…

As Andrew said, you can certainly host email/MX off DH, and I am doing this for my primary domain (hosting with everyone.net) while I host several other domains here and use the DH email services.

In my case, I told the registrar GoDaddy to use the 3 main DH name servers. Yes, we do need to use the DH name servers so that domain names can resolve within the DH data centers. DH needs the freedom to move servers around and even change their IP, and they have done so without the outside world losing access to our domains. You don’t have to worry about TTL on the DH server because if they move your server they’ll refresh the DNS. So in short, that’s all completely a non issue, never has been, don’t worry about it. I don’t recall the situation with getting a static IP but I believe you can pay a couple bucks for one if you need it, as is the case with many providers.

I’ll reset my name servers as indicated and put in a call to Support if that doesn’t work.
Thanks for your feedback.


#7

Recap/Summary: I changed the GoDaddy nameservers back to their default and after a few minutes of propagation time a browser visit showed their default page. I noticed that the DH admin page then showed that DH was no longer providing DNS for this domain. Good, it noticed. I reset GoDaddy to NS1.DREAMHOST.COM, etc, then clicked the reset in the DH panel (the “only once every 12 hours” thing). After some propagation time the default web page from my DH space then displayed for this site.

The trick was that button in the DH panel for resetting the DNS. “Something” got lost along the way and that kicked it in the pants.

HTH someone.


#8

Same thing is happening to me. Haven’t tried the reset but did try to “change” the domain information - still no go. Opened a DH support ticket. This has never happened in all the years we’ve been with DH.

PS: Where is this “reset” button? I’m guessing this isn’t on a shared server, correct?


#9

This has finally been resolved.