Unix-Pine and recent server change


#1

Does anyone around here, besides me, use Pine on a shell account?

Since the server change this week, I’ve had to make some adjustments in my .pinerc to keep things working. Two annoying problems remain:

– Pine can reply just fine to mail in the Inbox, but when I hit “c” to compose new mail, I get prompted for login credentials for friskymail-master.dreamhost.com. Only after the login fails (which takes a while) can I compose new mail. So–how do I get Pine to stop asking me for login credentials when I compose?

–Pine can’t list the saved-mail folders in my mail directory, even though SquirrelMail can see them. Under Pine, I can navigate to a folder directly, like this:

mail.mydomain.com/user=myuserid@mydomain.com/novalidate-cert}Inbox.foldername’

But if I ask Pine just to list the folders, I get prompted for login credentials for friskymail-master.dreamhost.com, and the login fails. So–how do I get Pine to display a list of folders in my mail directory?


#2

I had the same problem, which I just fixed successfully by deleting my .pinerc file. (Full disclosure: I deleted all .pine* files, too, although I don’t think this should matter.) Upon the next launch of Pine, I entered my username ("myuserid@mydomain.com") and password, and the problem went away.

Hope this helps!


#3

Agreed.

This worked here as well.

I must also mention that one of the biggest reasons I use DH is for Pine! It is so rare to have a working shell with nearly this much control but additionally allow me to have my pine!

Save [color=#CC0000]$97[/color] on all plans by using promo code: SRVR97. More Here


#4

Innnteresting! I just tried it and it worked, but with intolerable side effects. When I leave Pine to its default configuration on my shell account, it thinks my email address is my login name (which Dreamhost has forced to be mydomain@mydomain.com) rather than what I’d always intended it to be (david@mydomain.com). So my outgoing mail has an ugly-looking From address, and my incoming mail doesn’t get appropriately flagged to show that it’s for me.

In my .pinerc, I fixed those problems long ago by creating a “role.” I’ve gotta keep that.

So, grrr. I guess I might need to comment out my .pinerc line by line in the hope of figuring out which line causes the “compose” problem. And then hope it’s not a line I need.


#5

I just found a workaround:

Instead of hitting “c” for compose," I hit “#” followed by “c” and “y”. More keystrokes, but no delay.


#6

Hello all. I’m new to the forum and was just doing some searching on my Pine issue and came across this few month old thread. Anywho, I love using Pine when I’m away from my home box, but I’m not as savvy when it comes to using the shell commands as you guys. I’m having the same issues as you guys had after the migration to a new DH server. I’d like to delete my .pinerc file in the hopes it will restore my Pine back to pre-move perfectness. I’ve tried to delete this file but I can’t seem to?? Can you guys explain how to remove the file and any other pertinent files so I can have my lovely Pine working like normal again.

Thanks in advance.


#7

[quote]cd
[/quote]

[takes you to your home directory]

[quote]ls -a
[/quote]

[displays all files, including the hidden ones that start with a period, so you can verify that .pinerc is there]

[quote]rm .pinerc
[/quote]

[deletes or “removes” that file, but keep reading for a safer alternative]

[quote]mv .pinerc .pinerc-old
[/quote]

[renames .pinerc to .pinerc-old (or any filename you specify), allowing you to restore it back with the command below]

[quote]mv .pinerc-old .pinerc
[/quote]

[to get back to the way it was before]

Hope this helps!


#8

chanduput you rock!! I followed your instructions to rename my file and once I reconfigured Pine to my settings it opened and works just like a charm again. Thank you so much for your help. Just an FYI, I previously opened a ticket with DH support asking them to give me a hand with Pine and they told me that I’d have to come here because they could only help with normal clients, in a round about nice way.

Thanks again for the aid!


#9

Hrm, a strange thing just happened so i figured I’d put this out to you again chanduput (or any of you other Pine pros). I was logged into my “message index” reading my mail like normal, but when I try to go back to the “main menu” I’m asked for my login and password. I thought no big deal and reentered it and received a “formatting scroll text” message (usually normal). After the message I’m prompted to reenter my login and password again without actually getting out of the index screen. This just repeats itself as a loop until I cancel the login prompt and quit Pine. When I log back into Pine the after quiting I can navigate like normal until I want to go back to the main menu. I verified all my settings were correct in the options under “config”. Any ideas what would cause this or is there something I’m overlooking?

Thanks again in advance.