UNIX Command not working

apps

#1

There is a great tutorial on the Dreamhost Wiki about configuring Apple’s MAIL programm.
Link: http://wiki.dreamhost.com/index.php/Mac_OS_X_Mail_10.4

Everything worked according to this tutorial when I configured my MAIL app. Great stuff!

However using the terminal did not work, so I am still pestered with pop-up messages about a problem connecting to the mail server.

The problem is this

  1. I open the Terminal program and after the prompt I enter: # sudo -s, (just like it was said in the tutorial).
  2. After that I hit return and then I am not into the root. I am still in my user. The original prompt reappears.
    I have administratot rights. The version numbers of the Mac OS X is correct. I use 10.4.8.

Any Mac & UNIX savy person to the rescue, please.
Thanks in advance!
Cheers, HansNL


#2

How did you determine that you have admin privileges? Were you able to edit your hosts file successfully?

If you’re unsure if you’ve switched to the root user, you can type “whoami” (without the quotes). If you are root, it will tell you, otherwise it will return your regular username.


If you want useful replies, ask smart questions.


#3

You could try man sudo in terminal for more info.

Possibly your /etc/sudoers file needs update using visudo (man visudo), but you’d need to run that as root too, so…

Are you sure you’re logged in as a user that has Admin rights?


They hired more support help.
Tip me (and DreamHost gets 5%+$0.30) Cut the code: [color=#00CC00]9999[/color]=$99.99 Off


#4

While you can update /etc/sudoers manually on OS X, the correct way to give users sudo access is to simply tick the “administrator” box in the user account preferences. Members of the admin group are already included in sudoers.


If you want useful replies, ask smart questions.


#5

Thus my concluding question: “Are you sure you’re logged in as a user that has Admin rights?”


They hired more support help.
Tip me (and DreamHost gets 5%+$0.30) Cut the code: [color=#00CC00]9999[/color]=$99.99 Off


#6

Hi Guys,

Thanks a lot for trying to help me out! The main question you all ask is: “Do you have administrator rights?”

Well, I did a clean install of OS 10.4 some time ago. In the Help it says this: “When you set up Mac OS X, you create a user account that is also an administrator account.” So therefore I have the admin rights.

I tried that out by creating other users and give them administrator priviliges. I just wanted to see that effect of “fast user switching”. Well, that worked all right. After trying that out I deleted these accounts. So I am the only user on my computer.

In Preferences -> Accounts there is this box under the Adressbook card that should be ticked. That is the case.

Hope this clarifies my status as having an user account with Administrator privileges

Hope this gives more clarity.
Again thanks in advance!
Cheers, HansNL

UPDATE
I have been visiting Apple Discussions and found there that I could or should enable the root user. This could be done through the “NetInfo Manager utility” I had to set up a special root user password.

This worked fine and when I log in I can now choose between my “normal user” and the “root” Have to rush of to work now! 8-))

Cheers, HansNL


#7

It should be noted that you don’t type the pound sign (e.g., “# sudo -s” just means type “sudo -s”). A pound sign in bash tells it that everything following is a comment and thus ignored.

If you type “sudo -s”, you will see the following:


We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

Password:

That may have been the original problem.

Check out Gordaen’s Knowledge, the blog, and the MR2 page.