Unable to upload pics to WP


#1

I receive this message when I try to upload a picture to my header:

Unable to create directory /home/helwri1/findingthewrightbalance.com/wp-content/upLoads/2011/01. Is its parent directory writable by the server?

I tried to reset the default setting at Settings/Media/ upload files from the Admin

My domain name is from mydomains but hosted here

Thanks for any help, Helen


#2

There’s an upper case L in the path for “upLoads.” I’m betting it should be lower case, so go into wp-admin for Settings (Media, I think) and fix the path so it has no upper case letters.


#3

that doesn’t fix it :frowning: - thank you though


#4

It could actually be a permissions issue. WordPress codex has some info:
http://codex.wordpress.org/Changing_File_Permissions

As does a Google search for “wordpress uploads permissions”

You’ll need to use WebFTP or some other FTP client to log in and check the permissions.


#5

it still doesn’t work. I can’t find “wp-contents/uploads” in my files - the only sub directories are index, themes, and plugins. Should I just delete everything and download again?


#6

It wouldn’t surprise me if the uploads folder isn’t there. Create it and it should work with its default permissions.


#7

I have the same issue. Can not find where in WordPress settings to change path to “wp-content/uploads”. Found out of date answer from Dreamhost but WordPress interface is not the same and can’t find new location. Please help.


#8

oh really ?? “wp-content/uploads” doesn’t work ??
have you set permalink ? and can you list any plugin that you use and have you test in your own PC ?

[hr]

I find the way to solve the problem for you
please read on these list

  1. If you use subdomain chmod 777 folder every folder under lower level uploads/
  2. Flash Uploader Broken
    use this code put in .htaccess


    SecFilterEngine Off
    SecFilterScanPOST Off

Read more — >
unable-to-upload-pics-to-wordpress