Unable to login to Movable Type, due to upgrade?

apps

#1

Ever since the server OS upgrade, I have been unable to log into my Movable Type installation. After some research it seems a possible cause of my problem is if the BerkeleyDB was upgraded, then my old files will not be compatible with the new version. Unfortunately, I could not find the command ‘db_upgrade’ in the shell, so I cannot upgrade my
old databases myself.

Does anyone know the way to upgrade my old .db and .idx files to the new version? I installed mt-medic.cgi and according that I have NO authors, so that is why I suspect a database problem.

Thanks!!!

Here is a pertinent link:

http://www.sixapart.com/movabletype/kb/authors/invalid_login.html


#2

I got it to work, using the command

db4.3_upgrade *.db *.idx

to upgrade all the BerkeleyDB databases to the most recent version. Thanks.

My Path to Financial Freedom - MyMoneyBlog.com


#3

“db4.3_upgrade *.db *.idx”

How exactly do I issue this command? Apparently, I have to connect via ssh, but I’ve never done that before and it’s not exactly obvious what I have to do. I’ve tried following the prompts, filling in what I think is the right stuff, but the Terminal just ends up closing on me every time. Any tips for an ssh newbie?


#4

Oops. I figured it out. I hadn’t enabled ssh access in my control panel. Once I did that, everything worked fine.