Unable to install EPEL packages via yum on CentOS

dreamcompute

#1

I’m running a CentOS 6.6 instance and so far I have not been able to install any packages using yum that are in the EPEL repository. I have confirmed that the repository is installed.

[dhc-user@centos-6-5 ~]$ yum list epel-release
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.team-cymru.org
 * extras: mirror.team-cymru.org
 * updates: mirror.team-cymru.org
Installed Packages
epel-release.noarch 6-8 installed

When I run sudo yum install docker-io I get the response:

Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: www.gtlib.gatech.edu
 * extras: www.gtlib.gatech.edu
 * updates: www.gtlib.gatech.edu
No package docker-io available.
Error: Nothing to do

I ended up installing nodes from source which worked fine, but not sure I want to continue trying to install things from source.


#2

Hi reblevins,

I apologize but we do not offer CentOS as an operating system. If you have a dedicated server and have installed CentOS we are unable to offer support for that OS. Hopefully one of the veterans here will be able to help you.

Bump!

Thank you,

Amy F


#3

Note the section of the forum… Dreamcompute…

While I don’t have a dreamcompute instance, I do believe CentOS is an option.

"Freedom to choose your OS: Ubuntu, Debian, CentOS, Fedora and more. "


#4

Hi there,

I’ve had the same issue on my DreamCompute instance but it is running CentOS 7. However, I’ve found that the repo is renamed as “epel.repo.rpmnew”. I have to remove the .rpmnew extensions, run yum update, and it worked flawlessly.

So I did:

sudo mv /etc/yum.repos.d/epel.repo.rpmnew /etc/yum.repos.d/epel.repo yum update yum install whatever


#5

Ha! Worked like a charm!

Thanks for this info, I was about to give up on DreamCompute, but may give it a second chance now.
[hr]

Yeah, CentOS 6.5, 6.6 and 7.0 are all offered as images that can be installed in a DreamCompute instance.


#6

I apologize for the confusion on whether or not we offer CentOS. As correctly pointed out by LakeRat, we do offer many OS choices, including CentOS, on DreamCompute instances.

And thank you lshyrilser for helping out with the answer! This is the default behavior on rpm-based systems. The package manager tries to stop you from shooting yourself in the foot by not overwriting existing files. Sometimes helpful, sometimes not.