Unable to delete folder (FTP)


#1

Hello, I’m having a problem in which I cannot delete/access a couple folders in the ftp program. (cuteftp)

I’ve had this problem before when I’ve tried to delete a folder with a .htaccess in it, but got around that by changing options.
These folders are empty…no .htaccess file or anything and I cannnot delete it or access it.

Error mssg in the log says:
"ERROR:> Requested action not taken (e.g., file or directory not found, no access)."
Pop up mssg says:
“Request denied.
Verify that the file or folder exists and that you have the necessary permissions on the server to perform the requested operation”

Only thing I can think of that I did differently with these folders is that I added “*” in the title name, those didn’t show up either.

T.I.A. for any help.


#2

If you can telnet or SSH into your account, go to the parent directory and type:
/bin/rm -rf BADFOLDERNAME (whatever that is)

As I look at your message, if your folder name really has a * in it, I’m wondering how it ever got created, as that’s a wildcard character. With this in mind, you can type BAD* (whatever it is) in the above command if that folder’s first characters are unique. Whenever you type a *, you need to be extra careful that the leading characters are unique so you don’t delete other folders.

-Scott


#3

I’m sorry but I have no idea what telnet or SSH is…is there any other method I can use, or if you can could you explain how to use that.

For the folders when I created them with a “" the folder would be created but the "” doesn’t show up in the ftp program, but if I access it via browser then the “*” will show up.


#4

Have you tried the ftp page from the DreamHost control panel under ‘manage users’ and click the [login now] button.
You can then navigate to your web root (example.com) and see what is what!


Norm


#5

telnet and SSH are both fully covered in the wiki :slight_smile:

–Matttail
art.googlies.net - personal website


#6

Yesss…the ftp via manage users control panel worked!
Thanks for the help everyone =]