Unable to connect private network to public network

dreamcompute

#1

Hello

I am able to connect the router to public network, however, unable to connect private network to the router.

Check the following - https://www.dropbox.com/s/oyp7jteyrhrpaur/screenshot-dashboard.dreamcompute.com%202014-07-12%2023-48-13.jpeg

How to create the pointed link in a right manner?

Thanks


#2

Hi, same issue here.

I’ve created two instances and then try to associate public IP to one of them; after that I cannot reach it from here.

This worked a week ago, so I guess this is a problem on (beta) openstack infrastructure.


#3

There is a known issue with the network topology page now displaying the connection between the router and the private network.

http://wiki.dreamhost.com/DreamCompute_Known_Issues#Network_Topology

This should only be a display issue though and not really affect how networking functions.

Are you having issues reaching your floating ip addresses for your instances after adding them? If so, we can look into that for you.


#4

Yes, I’ve just created an instance from nova command line, following http://wiki.dreamhost.com/Launch_an_Instance_from_the_Command_Line . I cannot reach it via ping nor ssh, but traceroute show my packets are reaching to dreamhost network (208.113.128.0/17). I’m leaving my instance running if you wish to test this.


#5

Hi jjamor,

I just want to confirm, did you use the neutron commands to associate the floating IP? I ask because using the nova commands will not associate the floating IP properly.

If you’re still having issues connecting to it, create a support ticket if you haven’t already!


#6

Hi Justin

I added a floating IP to my instance post creation. However even ping doesn’t reach that IP.

I have terminated the instance, however, if you want to do some debugging, I can fire up one right away.

Thanks
Yugandhar


#7

Hey everyone, we found an issue where floating IPs associated to instances were not accessible over the weekend. We’ve fixed the issue and are working on figuring out what happened.

You can either disassociate the floating IP from your instance and associate it again, or terminate the instance and start with a new one and it should work.


#8

Yes, it works now. Many thanks!


#9

It seems to me like this problem is still happening.

I will try one more time to re-associate the IP with the instance.
However I am also getting errors in the console when creating keyPairs

Error: Unable to create keypair: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-dc543a0c-ad26-4ff9-a021-0e469118e2ef)


#10

I just replied to your other post and just saw this. If you’re seeing errors creating a keypair, then there is some other problem. As I mentioned in the other post, contact our tech support team so we can find out who you are and take a look at your account!