Unable to change php version


#1

“php --version” tells me my php version is 4.4.8
I want to change it to version 5 but the selection in Manage Domans > Web Hosting has been removed.

Can someone please let me know how to change the php version?
Thank you.


#2

The php version in shell is 4.4.8
I figured out that php version 5 can be found at /usr/local/php5/bin/php therefore I made an alias for this in my .bash_profile so that the bash command “php5” runs php version 5


#3

And can you tell me exactly “how” you did that? :slight_smile:


#4

Type this into your shell: echo alias php5=/usr/local/php5/bin/php >> ~/.bash_profile


#5

OK, did that and thank you.

I guess I’d better check to see if this is what I need to do. My server got “upgraded” and killed my custom install of php. I went to the wiki and followed the instructions there to reinstall and it keeps stopping the process. Mind you, this is the only time I’ve ever used shell (PuTTY)? is to do this. I can code and I can follow instructions. It gets all the way to the c-client section and does this:

[quote]— Building: c-client

Making…
[tethys]$

[/quote]

I tried it line by line, and it can’t find c-client.a or something like that. Neither can I. There’s a c-client.h, but no “.a”.

So, I figured I’d skip the c-client section and jump to the actual php configuration section. I get a similar drop, so I go into the shell and do individual commands. I use the following configuration:

[tethys]$ ./configure --prefix=/home/mysitename/php5 --with-config-file-path=/home/mysitename/php5/etc/php5/mysitename.com --enable-fastcgi --enable-force-cgi-redirect --with-xml --with-libxml-dir=/home/mysitename/php5 --with-freetype-dir=/home/mysitename/php5 --enable-soap --with-openssl=/usr --with-mhash=/home/mysitename/php5 --with-mcrypt=/home/mysitename/php5 --with-zlib-dir=/home/mysitename/php5 --with-jpeg-dir=/usr --with-png-dir=/usr --with-gd --enable-gd-native-ttf --enable-memory-limit --enable-ftp --enable-exif --enable-sockets --enable-wddx --with-iconv=/home/mysitename/php5 --enable-sqlite-utf8 --enable-calendar --with-curl=/home/mysitename/php5 --enable-mbstring --enable-mbregex --with-mysql=/usr --with-mysqli --without-pear --with-gettext

and I get down to the configuration extension stuff and get…

Configuring extensions
checking whether to enable LIBXML support… yes
checking libxml2 install dir… /home/mysitename/php5
checking for xml2-config path… /home/mysitename/php5/bin/xml2-config
checking whether libxml build works… yes
checking for OpenSSL support… yes
checking for Kerberos support… no
checking for DSA_get_default_method in -lssl… no
checking for pkg-config… /usr/bin/pkg-config
configure: error: Cannot find OpenSSL’s <evp.h>
[tethys]

I’ve been working on this since the darned server got upgraded and I’ve put about 15 hours into it. I’m spent.

So, what I am now trying to do is get a working version of php somewhere that I can use it with “enable soap” and “enable openssl”. I think those are the two things I need that are different than the standard install from Dreamhost.

Am i on the right path here?

If so, now what do I do with that “bash” to get my site to work? :slight_smile:

Thanks for any help.


#6

OK, I just did the php --version on shell and got the 4.4.8

But I thought to do the phpinfo() on my site to see if any previous attempt has taken, and it’s showing version 5.2.6.

So far so good (somehow) but I do not see “enable-soap” in the configuration settings. I know this is probably elementary, but how do I change that to enable soap?


#7

OK, this is more than just changing versions. I’m sorry to have gotten this thread off topic. I’ve started a new thread with my issue explained here