Uber uploader flength error

software development

#1

I know it’s been talked to death on this forum in the past, but all the posted solutions haven’t helped me, or were “fixed” by private IM…so I’m asking again in the hope someone will help.

I’m using uber-uploader on a standard shared account. If I disable “Enhanced security” for the subdomain the upload scripts are on, it works fine. If I re-enable them, the uploads work, but i get the “Failed to find flength file” error that’s caused by mod_security filtering things. I’ve tried lots of combinations of the .htaccess files that come with uber-uploader, along with various suggestions on the web (and this forum), and none of them have any effect.

The install is fine, as without enhanced security it all just works, but with it, I can’t get the progress bar. I even tried using a separate subdomain just for the uploads, with mod_security disabled…but then I have problems with cross-domain javascript when I try to include that in my main site…

Anyone got suggestions? Anyone fancy holding my hand through fixing this?


#2

Depends what server you’re on.

<IfModule mod_security.c> SecFilterSelective REQUEST_URI "^/[color=#0000CC][upload_script_name][/color]\.php.*$" "allow,pass" </IfModule>Should that fail, see new server directives here: http://wiki.dreamhost.com/Server_Moves#.htaccess_changes

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

Thanks for the pointers. Having read the wiki stuff and attempted unsucessfully to use the “new style” directives, it looks like it’s “all or nothing” now.

"Additionally, will no longer have any effect.

These manage mod_security, which can now be turned on and off from the ‘Manage Domains’ section of your panel. You should remove any lines referring to mod_security from your .htaccess file and manage that via your control panel instead. "

Not really seeing how that’s an upgrade, but hey, that’s just me!

Thanks anyways for the assist.