Typo installation help

software development

#1

I’ve gone through and installed typo via svn and many of the tutorials online. I’ve setup my cp to direct to /my/typo/public and populated the db via mysql command.

But, for some reason I cannot access the site without loading it via ruby script/server (./script/server). I can load it via the ports I specify during webrick (I can view the site at different ports - 3304, 3000, etc). I’ve been able to view it via production and development.

But, again, I cannot have it just run like normal. I want to be able to not have to load webrick via ssh and leave the instance running. Also, I would like to not have to specify a port. How do I do this?


#2

I had the same issues at first. I initially had all of the files from the typo archive within www.mydomain.com/ and it only worked, like you mentioned, when i had the server/script running via a port number.

I changed my web directory from /home/username/mydomain to /home/username/public

I’m still not convinced that everything is setup correctly so if you or anyone else has advice feel free to share.

Some things I’m unsure of:

  • do we need to change the path to ruby in dispatch.fcgi and dispatch.rb ?
  • The docs page on typosphere.org mentions that there are different instructions for installing/enabling FastCGI… not sure what those are or if I just need to check the box in control panel.
  • What’s the “correct” file and domain structure? I’ve seen a number of things mentioned like sym links to the public folder, installing in sub-folders, using sub-domains etc. I just want to install to www.mydomain.com if possible.
  • I never came across any “install” process nor the migrate procedure… what’s the deal?

Let’s work to figure this out.

-J


#3

I will try and do what you’ve mentioned, but it seems strange that you could make the site work by negating the mydomain part, how would it know where to direct to. I currently have it pointed to my public, but still can’t get it to run full time, only when I initiate the script.


#4

Oops… I meant /home/username/mydomain/public. You’re right, it wouldn’t know where to direct to without the mydomain part. Sorry about that.


#5

Did you follow the wiki (http://wiki.dreamhost.com/index.php/Ruby_on_Rails)? I did and got my rails running on apache no problem.

If you can view typo with WEBrick, but not on Apache then you most likely have a configuration problem on the apache end and not anything to do with typo or rails.


#6

I just figured out the minimal steps required to install and run typo on DreamHost. I created a step-by-step guide, so people can get typo installed and running quickly.

www.rowbee.com/articles/2006/03/17/typo-on-dreamhost

Have Fun.