Twiki authentication overly zealous

apps

#1

hello,

I’ve migrated a twiki wiki from another virtual host to dreamhost at

http://www.tokeru.com/twiki

Everything appears to have moved across ok, but I’m getting annoying authentication requests. Twiki keeps asking for users to login even when just viewing a page. If you cancel the request the page will load fine, but it will usually ask for a username/password twice before doing so.

I’ve read though the install notes several times, and through the great notes written by both richard donkin and torben gb, but can’t sort this one out.

I’m not getting any errors in my error log, and the access log seems fine. The access log might be a clue though, for every view request it seems to be trying to run viewauth, like this:

82.35.82.76 - - [24/Nov/2004:05:17:55 -0800] “GET /twiki/bin/viewauth/Main/%USERSTYLEURL% HTTP/1.1” 401 3599 “http://www.tokeru.com/twiki/bin/view/Main/MayaOptimisingRenders” "Mozilla/5.0 (Macintosh;…

Something else I tried was adding an entry for the view executable to my twiki/bin/.htaccess file, like

<Files “view”>
allow from all

But that hasn’t worked either. Any ideas?

Thanks,

-matt


#2

Hi Matt,
For DH issues, this is the best place to ask. For issues about the internals of TWiki, there’s also the TWiki.org support web where you might be able to find the issue explained already, and if not, then you can post it there.

Off the top of my head, I don’t have any idea about your problem, but I’ll keep it in mind and perhaps revert later.

TorbenGB
Try out DreamHost with a free WebIDPrices, options


#3

Ah, found the problem over at twiki.org, thanks for the link. Its a bug in the pattern skin, explained here:

http://twiki.org/cgi-bin/view/Codev/CairoAsksForPasswordTwice