Trying to set up django

software development

#1

I’m setting up django according to the instructions at http://wiki.dreamhost.com/Django. I am using Winscp.

When I get to the part were I execute command:

python django-setup.py

I get “Host is not communicating for more than 15 seconds. Still waiting…”

It never does anything.

I can see the django-setup.py file is in the right directory, so I know it’s in there.


#2

How are you executing that command? The error message you’re describing isn’t one that the script would ever generate.


#3

I’m executing from the command line from Winscp.


#4

That’s perfectly normal behavior :wink:

WinSCP is just letting you know that the server hasn’t responded back (yet!) so just wait patiently for the script to finish server-side, after which the server will send a response to WinSCP and all should be good.


#5

The Django install script is interactive — if WinSCP is just trying to run it and wait for it to finish, it’ll never get anywhere. You’ll probably need to switch to a SSH client (like PuTTY) for this job.


#6

New Problem:

Can’t get Django admin site to work.

I tried the following commands …

python manage.py runserver python manage.py runserver 8080 python manage.py runserver 0.0.0.0:8080

The develop server runs but when I use the web browser on the above I get “This webpage is not available” errors. I had to change the port to get it work initially because of “port in use” errors but I got past that by changing the port.

I tried this as well…

and I get Page not found (404)

The development server seems to working, but I can’t get to the admin site