Trying to get IMAP to work

dreamcompute

#1

I’m trying to move my domain (defaria.com) -> Dreamhost Compute. I got most of it set up but I have not managed to connect to IMAP. I have IMAP (Courier) running and from my Dreamhost compute server I can telnet localhost 143 and I see the server respond. But if I telnet 208.113.131.137 143 from my defaria.com server I do not get a response. Smells like the port 143 is being blocked but I think I put in the right command to open that port. I used:

iptables -A INPUT -p tcp --dport 143 -j ACCEPT

as well as

ufw allow 143

but neither worked.

Also, as it stands I have to ssh in as dhc-user@. I’ve created a user for myself (useradd andrew) but I cannot ssh andrew@. When I try I get “Permission denied (publickey)”. Do I have to make a user through some other means?

Finally, is there a name for this server or do I have to use the IP address forever? I guess when I’m satisfied that it’ll work for my domain I will move the ip address for defaria.com to point here.


#2

Did you set the security group in your machines? This article has instructions on how to do this within the dashboard:


#3

Sounds like you have a lot of that figured out. Firewalls aren’t setup by default on your instance, but there are ‘security groups’ that acts like firewall templates if selected for an instance. In the DreamCompute dashboard, if you check out Access & Security -> Security Groups, make sure that TCP port 143 is added for ingress and it should open it up for outside connections.


#4

Hmmm… It seems like you’re saying that if I set up my security group properly I can get IMAP working correctly such that I can read email using Thunderbird from my laptop at home. The page that I was pointed to talked about using a command named nova. Well I have no nova command but from what I’m reading it’s a python thing that I need to install (there’s a lot to install). I’m installing it on my server at home. Hopefully that’ll get me working properly…

Can I use my already existing ecliptic curve DSA key (~/.ssh/id_ecdsa.pub)?

I tried the nova command there to upload this key and got:

Defaria:nova keypair-add --pub_key ~/.ssh/id_ecdsa.pub defaria.com
ERROR (CommandError): You must provide a username or user ID via --os-username, --os-user-id, env[OS_USERNAME] or env[OS_USER_ID]
Defaria:

Trying to generate a keypair elicits the same error.

Wait! Am I supposed to install this stuff on my instance or my current, existing server? I tried it on both with essentially the same error. If I add --os-username it then asks for --os-project-name:

Defaria2:nova keypair-add --os-username $USER KEY_NAME > MY_KEY.pem
ERROR (CommandError): You must provide a project name or project ID via --os-project-name, --os-project-id, env[OS_PROJECT_ID] or env[OS_PROJECT_NAME]. You may use os-project and os-tenant interchangeably.
Defaria2:

Note: Defaria is my current server at home and Defaria2 is my Dream Compute instance.


#5

I’ve made some progress by using the Dream Compute’s web site to add IMAP to the default security group. I am now able to telnet into port 143 from home and I see a response from the server. However I cannot configure Thunderbird to use it. Note I’ve been using Thunderbird (and Netscape mail before that) forever and have configured it to receive and send email from a variety of servers. What am I doing wrong? As I don’t have a name for this server I’m using the IP address. So my email address is andrew@208.113.131.137. I’ve added the user andrew and even set it up so I can ssh into the instance. However with IMAP protocol you specify a username and password. The username is andrew and I’ve set the password so I know it’s correct, yet I keep getting “Thunderbird failed to find the settings for your email account” every time.


#6

OK I think I got it all now. I switched back from Courier IMAP -> Dovecot imap and got it all working.